Loading

CloudHub 2.0 - Debug logs that previously worked in CloudHub 1.0 are not appearing

Fecha de publicación: Feb 5, 2025
Solución

SYMPTOM

You cannot see certain Debug logs in CloudHub 2.0 Application logs, which were previously visible in CloudHub 1.0 logs, or showing on Anypoint Studio console.

CAUSE

Certain modules use java.util.logging instead of Log4j2 logging library for logging. The java.util.logging API outputs the logs to the Console (such as stderr), which by default is not forwarded to the log aggregator on CloudHub 2.0.

SOLUTION

Add the property below to your CloudHub 2.0 application:
forwardConsoleLogToAnypointMonitoring.enable=true

  • One scenario that requires this setting to be enabled on CloudHub 2.0 is SSL Debug logging as described in How to enable SSL debug logging in MuleSoft Products.
  • Another scenario is SMTP debug logging.
    For CloudHub 2 app, in addition to the SMTP Debug setting (i.e <email:property key="mail.debug" value="true" />), the extra app property (forwardConsoleLogToAnypointMonitoring.enable=true) is required since SMTP debug logging uses java.util.logging API to send logs to console, differing from log4j2 logging (such as HTTP verbose logging). Without the above property setting, SMTP debug logs will not appear in the app logs.
Número del artículo de conocimiento

001117385

 
Cargando
Salesforce Help | Article