Loading

PCE 3.1.0 Mule App Stuck in "Starting" and Application Manager Service Logs show "Read Timeout"

Udgivelsesdato: Aug 6, 2025
Løsning

SYMPTOM

PCE 3.1.0 Mule App Stuck in "Starting" and Application Manager Service Logs show "Read Timeout"
{"timestamp":"2023-09-05T18:17:54.098Z","level":"ERROR","thread":"thread_pool_executor-20","mdc":{"transaction-info":"cid=1 tid=a8caec27","transaction-id":"a8caec27"},"logger":"com.mulesoft.hybrid.storage.s3.S3FileStorageProxy","message":"Failed to put file { bucketName=ch-application-files-dev, path=1/applications/10079/my-test-file-api-1.0.0-SNAPSHOT-mule-application.jar, contentType=application/java-archive, contentLength=110393698, encryption=null, file=true }. Exception: ","context":"default","exception":"com.amazonaws.SdkClientException: Unable to execute HTTP request: Read timed out\n\tat com.amazonaws.http.AmazonHttpClient$RequestExecutor.handleRetryableException(AmazonHttpClient.java:1216)\n\tat com.amazonaws.http.AmazonHttpClient$RequestExecutor.executeHelper(AmazonHttpClient.java:1162)\n\tat com.amazonaws.http.AmazonHttpClient$RequestExecutor.doExecute(AmazonHttpClient.java:811)\n\tat
 

CAUSE

The default timeouts for connecting to Cassandra S3 service may be too low.

SOLUTION

Please edit the config map for application manager service and change the two values to below:
 
kubectl get cm application-manager-service-env -n arm -o yaml
kubectl edit cm application-manager-service-env -n arm

HYBRID_STORAGE_S3_BUCKET_CONNECTION_TIMEOUT:30000
HYBRID_STORAGE_S3_BUCKET_SOCKET_TIMEOUT:90000

Then, delete the application-manager-service pods in arm namespace. Finally, retry the deployments again.
Vidensartikelnummer

001117578

 
Indlæser
Salesforce Help | Article