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Intermittent connection error - "Remote host closed connection. Possible SSL/TLS handshake issue."

Publish Date: Mar 2, 2024
Resolution

SYMPTOM

You are seeing intermittent connection errors. This can range from various connectors, anywhere from using the HTTP requester or a DB connection.


CAUSE

This can have numerous causes:

  • HTTP requester may be using persistent connections that may be killed after a period of inactivity. 
  • Possible SSL or certificate issue
  • The other end is disconnecting the connection.

SOLUTION

  1. If you are using a connector that has persistent connection as an option, try disabling this option to see if it makes a difference.
  2. To troubleshoot if this is a SSL or certificate issue, please enable SSL debug logging: How to enable SSL debug logging in Mulesoft Products and How to diagnose "java.io.IOException: Remotely Closed" in HTTPS outbound calls
  3. To rule out a possible issue with the payload and headers being sent, please enable HTTP Debug logging and compare the problematic payload with a successful payload in cURL or Postman: How to Enable HTTP Wire Logging for the HTTP Connector
  4. Finally, if none of the above works, please setup a rolling tcpdump and analyze the contents in Wireshark as soon as the issue is reproduced. The goal is to see which side sent the termination and correspond the timestamps with the logs from step 3. Here are more instructions: How to Capture Network Traffic Between Two Systems
Knowledge Article Number

001118166

 
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Salesforce Help | Article