Loading

Connect to SAP gateway failed - Trying to establish connection with SAP

Publiseringsdato: Mar 2, 2024
Løsning

SYMPTOM

When trying to connect to SAP Gateway, the following error appears in the application log file: 
Failed to connect/reconnect: SapConnector { name=SAP lifecycle=stop this=69b0f893 numberOfConcurrentTransactedReceivers=4 createMultipleTransactedReceivers=true 
connected=false supportedProtocols=[sap] serviceOverrides=<none> } . Root Exception was: Connect to SAP gateway failed Connection parameters: TYPE=”” DEST= “” 
ASHOST=”” SYSNR=”” SAPROUTER”” PCS=”” LOCATION CPIC (TCP/IP) on local host with Unicode ERROR partner ‘’ not reached TIME Fri Apr 13 10:11:04 2018 RELEASE 721 
COMPONENT NI (network interface) VERSION 40 RC -10 MODULE nibuf.cpp LINE 4658 DETAIL NiBufIConnect: connection pending after 60000ms SYSTEM CALL connect ERRNO 115 
ERRNO TEXT Operation now in progress COUNTER 2 . Type: class com.sap.conn.rfc.exceptions.RfcException

CAUSE

This behaviour is caused by the SAP Connector being unable to reach the SAP Gateway. This could be caused by the SAP Gateway failing or being mis-configured or an underlying network issue.

SOLUTION 

You will need to troubleshoot the networking connections to the SAP Gateway and ensure that the SAP Gateway is Running.

For the former, from the Mule server, use the following tools to determine if you can reach the SAP IP/port.

1) Ping the SAP Server IP. After obtaining the IP address or the hostname of the server run
ping x.x.x.x or ping SAPhostname

where 

$ ping SAPhostname
PING SAPhostname (184.168.221.34): 56 data bytes
64 bytes from 184.168.221.34: icmp_seq=0 ttl=53 time=126.273 ms
...
is a ping that is able to reach the server in question

2) Run a traceroute (or tracert on Windows) to the SAP Server to see where the connection fails, bearing in mind that a line of three asterix like this 9 * * * will mean either it cannot be reached or a traceroute doesn't reveal the server information of the step (it's turned off for that server.) A good connection will complete with the last line of the output giving the hostname.
 
$ traceroute hostname
traceroute to hostname (184.168.221.34), 64 hops max, 52 byte packets
 1  192.168.8.1 (192.168.8.1)  0.663 ms  0.304 ms  0.276 ms
...
12 hostname (184.168.221.34)  2.932 ms  3.015 ms  2.934 ms

3) Perform an nslookup on the SAP Gateway. Appropriate if the SAP Server is external to your organization.

$ nslookup hostname.anothersite.com
Server: 90.152.3.202
Address: 90.152.3.202#53


Non-authoritative answer:
hostname.anothersite.com canonical name = anothersite.com.
Name: anothersite.com
Address: 184.168.221.34

4) Attempt to telnet to the SAP IP/port. The SAP Gateway default ports are 3300 or 4800 (although there are many TCIPIP Ports that can be used). The command to use is telnet hostname port.

5) To determine if the SAP Gateway is the cause of the issue, you will need to involve the SAP Administrator, but essentially some simple steps such as the ones given in this SAP Gateway Article will determine if this is a SAP issue.
Knowledge-artikkelnummer

001118393

 
Laster
Salesforce Help | Article