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PKIX path building error in Mulesoft Anypoint Studio when connecting to Anypoint MQ

Date de publication: Jul 25, 2025
Résolution

SYMPTOM

From Anypoint studio when trying to connect with Anypoint MQ, you see following error on Anypoint studio console.
 
ERROR 2023-01-02 18:55:54,997 [[MuleRuntime].uber.04: [ct-invoices-proc-api-mule].uber@com.mulesoft.extension.mq.internal.connection.AnypointMQConnectionProvider.connect:122 @21e984c6] [processor: ; event: ]
com.mulesoft.mq.restclient.client.mq.AbstractCourierRestClient: Error from GET https://mq-us-east-1.anypoint.mulesoft.com/api/v1/serviceRegistry. PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: 
unable to find valid certification path to requested target | PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target | unable to find valid certification path to requested target
 

CAUSE

There are following two possibilities due to which you encounter this Error.
1) Issue with the installed JDK version/JRE version. 
2) The organisation firewall rules blocking the traffic.

SOLUTION

1. Issue with the JDK.

1) Check the Java version on your machine (using java -version command) and if there are multiple version installed so OpenJDK 8 version must be set in JAVA_HOME environment variable. If not follow below step.
2) Change the JDK to OpenJDK and Set the user and system Environment variable for JAVA_HOME.
3) Make Sure you have downloaded the OpenJDK in above step.
4) Login to anypoint.mulesoft.com in browser and download the certificate and export to the cacerts folder of downloaded OpenJDK above using KeyTool Command.
5) Restart the Studio.


2. The organisation firewall is blocking the traffic.

To confirm, run following commands from your machine and see if you get the connectivity to respective hosts or not. There are two approach to confirm this.

First Approach

> nc -vz anypoint.mulesoft.com 443
> nc -vz <mq_region>.anypoint.mulesoft.com 443

OR
> telnet anypoint.mulesoft.com 443
> telnet <mq_region>.anypoint.mulesoft.com 443

Second Approach

Go to the Window>General>Network Connection to Direct and Manual, Reverse the existing configuration
Or Change the Internet Connection, Like use your mobile network , just to check
Or Set the Proxy , Ask your Org Admin to send the proxy network details to configure in network connection of Studio.

 

Attachments

https://mulesoft.my.salesforce.com/5002T00001NMrNm

Numéro d’article de la base de connaissances

001119664

 
Chargement
Salesforce Help | Article