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Logs Appear Delayed in Anypoint Monitoring (CloudHub/RTF)

Publish Date: Mar 2, 2024
Resolution

SYMPTOM

This affects CloudHub and RTF applications.
Logs are correctly sent and can be viewed from Anypoint Monitoring Log Search, but are showing up with a delay.

CAUSE

This can be caused when the JVM is using a custom timezone, i.e., How to properly set the TimeZone in Mule (Mule Runtime and CloudHub).

SOLUTION

As documented in Logs in Anypoint Monitoring, Anypoint Monitoring has a requirement where CloudHub and RTF applications must use the default UTC timezone. If this configuration is modified, the logging will still work, but it will introduce a delay in the logs as Anypoint Monitoring will treat the modified timestamps as UTC - even though it has been modified to a different timezone.

 
Knowledge Article Number

001121549

 
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