Loading

Unable to revoke API Groups and Contract from API Manager.

Fecha de publicación: Jul 18, 2025
Solución

SYMPTOM

The user migrated Okta from the trial version to the licensed version and then tried to remove old instances of API Groups and Contracts from API Manager. But it throws an error while revoking API Groups and Contracts.

Error: "The Application associated with this contract was marked for deletion by an external system. Please delete the contract." 
 

User-added image

CAUSE

This could happen if the users modify the permissions in an external IDP (for example deleting the permissions there).

SOLUTION

Below REST APIs can be used to delete the contracts and API Groups.

To Delete Contracts:
Verb: DELETE
Endpoint: https://anypoint.mulesoft.com/apimanager/api/v1/organizations/{organizationId}/environments/{environmentId}/groupInstances/{groupInstanceId}/contracts/{contractId}
https://anypoint.mulesoft.com/apimanager/xapi/v1/organizations/96xxf3b3-c4e3-4x54-bfcb-4cexxxfc73f/environments/4ebacc4f-xxx-47b6-8adc-41fa0082c6b6/groupInstances/71175/contracts/2430788

Once you have successfully deleted the contract, you can try deleting the API group from UI and if that doesn't work then please use below REST API to delete the API group.

To Delete API Group:
Verb: DELETE
Endpoint: https://anypoint.mulesoft.com/apimanager/api/v1/organizations/{organizationId}/environments/{environmentId}/groupInstances/{groupInstanceId}

For more information about these REST API calls please see the API Manager API

 
Número del artículo de conocimiento

001121697

 
Cargando
Salesforce Help | Article