Loading

How to access modules via AnypointPlatform login when the authentication is SSO and OKTA enabled?

Fecha de publicación: Aug 6, 2025
Solución

SYMPTOM

How to access modules via AnypointPlatform login when the authentication is SSO and OKTA enabled? Anypoint Studio is not showing the button in the Anypoint Platform login to redirec to the Okta page in the Browser in Anypoint Studio

CAUSE

When SSO and Okta are enabled, it is needed to add some extra steps in the configuration

SOLUTION

1) First, we need to get the URL of the External Identity. To do that login in Anypoint Platform and go to Access Management -> Identity Providers.
Here you will see the list of the Identity providers defined. Now click on the 3 points on the right side of the page in the line of the Identity Provider that you need to configure in Anypoint Studio.
2) Click on Copy Direct Link
3) Now you get a link similar to the next:

https://anypoint.mulesoft.com/login/domain/mydomain/providers/5f73c779-9b5d-4bde-b69b-a0a0eb57f1e2

4) Copy all the URL after the domain section, in this case, you will get:

mydomain/providers/5f73c779-9b5d-4bde-b69b-a0a0eb57f1e2

5) Open Anypoint Studio, and go to Preferences -> Anypoint Studio -> Authentication -> Add
6) In the window you will see a button in the right corner that says "Configure", click on that button.
7) Here, select the Option External Identity
8) In the Organization Domain field, copy the URL that you got in step 4.
9) Click OK, an you will be able to see the right page to login.

 
Número del artículo de conocimiento

001121705

 
Error notificación,
Error
An error occurred during retrieving a vote
Pulse Control + F6 para navegar a la siguiente notificación emergente o región enfocable.
Error notificación,Error An error occurred during retrieving a vote Pulse Control + F6 para navegar a la siguiente notificación emergente o región enfocable.
Cargando
Salesforce Help | Article