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413 Request Entity Too Large Error in CloudHub

Data pubblicazione: Dec 18, 2024
Risoluzione

SYMPTOM

When sending a request to a CloudHub application either via the CloudHub Shared Load Balancer or the CloudHub Dedicated Load Balancer with a large payload, a 413 error is returned.

413 Request Entity Too Large


CAUSE

This is the expected response if the max post size is exceeded in the shared load balancer or dedicated load balancer.

The dedicated load balancer will support up to 1000 MB Max Post Size (Payload Size)
The shared load balancer will support up to 1000 MB Max Post Size (Payload Size)

If the max post size exceeds these limits, the request is blocked and a HTTP 413 error will be returned to the client.


SOLUTION

Re-factor your application to send smaller-sized payloads. HTTP is a non-transactional, stateless protocol, it is not designed for long-running transactions or extremely large transactions. It may be more appropriate to use a different connector or protocol for such use cases, such as SFTP.

You can bypass the shared load balancer or dedicated load balancer by using the mule-worker or mule-worker-internal URL for your CloudHub application. Achieve this by having your request go directly to your CloudHub worker. For reference, please consult cloudhub-networking-guide
 

NOTE

Dedicated Load Balancers, as of the 11 May 2022 release, has the option to enable HTTP Steaming Mode. This mode is OFF by default, and can be enabled via API call to allow streaming payloads. This can help avoid the 1000mb max post limitation. Please see this article to learn how to enable HTTP Streaming in your DLB.

 

Numero articolo Knowledge

001122438

 
Caricamento
Salesforce Help | Article