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Unable to install RTF operator on OpenShift with error: "no operators found in channel"

Fecha de publicación: Oct 29, 2024
Solución

SYMPTOM

The operator status is unknown, and the operator upgrade status is unknown failure. The catalog operator logs display the message "no operators found in channel."

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CAUSE

The operators were not upgraded before, and the operator update channel being used in the subscription is not available post Red Hat Openshift Container platform upgrade.

SOLUTION

Follow the below steps to resolve the issue:
  1. Check the logs of the catalog operator pod using the following command: 
    $ oc get po -n openshift-operator-lifecycle-manager
    $ oc logs catalog-operator-xxxxxxxxxx-xxxxx -n openshift-operator-lifecycle-manager
  2. Look for the following logs in the output: 
    Event(v1.ObjectReference{Kind:"Namespace", Namespace:"", Name:"openshift-operators", UID:"xxxxxxxxxxxxxxxxxxx", APIVersion:"v1", ResourceVersion:"xxxx", FieldPath:""}): type: 'Warning' reason: 'ResolutionFailed' constraints not satisfiable: no operators found in channel 4.6 of package <operator-name> in the catalog referenced by subscription <operator-subscription>, subscription <operator-subscription> exists

     
  3. Update the subscription channel and upgrade it as per the documentation to resolve the issue


DIAGNOSTIC STEPS:

Check the logs of the catalog operator pod to identify the error messages and determine the root cause of the issue. Once the cause is identified, follow the recommended solution to resolve the issue.

This solution was provided by RedHat Knowledge base, and it is not standard part of MuleSoft Support.

Full RedHat article can be found here:
https://access.redhat.com/solutions/6961923

I hope this article helps you in resolving the issue. If you still face any issues or need further assistance, please reach out your OpenShift administrator or RedHat Support.

Número del artículo de conocimiento

001123327

 
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