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CloudHub Autoscaling Policy not adding more workers or not triggering

Veröffentlichungsdatum: Jul 16, 2025
Lösung

SYMPTOM

After configuring CloudHub Autoscaling policy (you can find more information, and how to configure this feature here), you notice that the policy is not triggering, or no new workers are added.

CAUSE

Possible causes for this are:
  • Parameter values not realistic according to this feature limitations.
  • Your application is already using 4 workers.

SOLUTION

When using the Autoscaling feature, there are some considerations to keep in mind.

Considerations

1. CPU usage (%) parameter value:
Values considered reasonable for this parameter start at 50% or 60%. Values lower than that may be easily pass by Mule Runtime startup process.
We recommend performing the autoscaling policy test after the cooling period after the Mule Runtime is started.

2. "No other scaling policy applied" minimum value is 30 minutes, and cannot be reduced.

3. There is a limit of 4 workers for horizontal scaling and 16 vCores for vertical scaling.

4. Autoscaling is not triggered for short bursts of load. CloudHub metrics that are used for the triggers are measured in averages over a 5 minute interval. Based on this, at least 5 minutes of over threshold is required. For a new worker to join, it can take several minutes or longer, depending on underlying infrastructure availability.
 

Note

To use the autoscaling feature, your organization must have an Enterprise License Agreement (ELA). Entitlement is approved based on qualified use cases.
If you are interested in this feature, contact your account representative.

 
Nummer des Knowledge-Artikels

001123405

 
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