Loading

Error "Peer certificate cannot be authenticated with given CA certificates" al conectarse a Presto

Fecha de publicación: Aug 24, 2022
Descripción

Después de sustituir el certificado SSL en un servidor de base de datos de Presto, puede aparecer el siguiente error a la hora de conectarse a la base de datos:

Unable to connect to the ODBC Data Source. Check that the necessary drivers are installed and that the connection properties are valid. (No es posible conectarse a la fuente de datos ODBC. Compruebe que se han instalado los controladores necesarios y que las propiedades de conexión son válidas.)
[Simba][Presto] (1020) Error with HTTP API at https://
<server address>:9443/v1/statement : Peer certificate cannot be authenticated with given CA certificates (Error de comunicación de Internet: No se puede autenticar el certificado de pares con estos certificados CA)
Unable to connect to the server "https://
<server address>". Check that the server is running and that you have access privileges to the requested database. (No se puede conectar con el servidor "<dirección de servidor>". Compruebe que el servidor está en ejecución y que dispone de privilegios de acceso a la base de datos solicitada)

Cause

El certificado SSL usado por Tableau para establecer la conexión no coincide con el nuevo certificado SSL del equipo del servidor de la base de datos.
Solución
Colabore con su equipo de TI para sustituir el archivo cacerts.pem en la subcarpeta lib de la carpeta de instalación del controlador ODBC de Simba Presto con el archivo cacerts.pem del servidor de base de datos de Presto.
Recursos adicionales
Configurar la verificación de SSL
Nota: aunque nos esforzamos para que las referencias a contenidos de terceros sean lo más precisas posibles, la información proporcionada puede variar sin previo aviso.
Número del artículo de conocimiento

001471053

 
Cargando
Salesforce Help | Article