Loading

Cuando se utilizan archivos Landscape XML de SAP BW, la lista desplegable de selección de conexión está vacía

Fecha de publicación: Jul 20, 2023
Descripción

Cuando se utilizan archivos Landscape XML de SAP BW, la lista desplegable de selección de conexión está vacía, aunque todas las conexiones se muestran según lo esperado en el inicio de sesión de SAP.

Cause

Los archivos Landscape XML deben encontrarse en \AppData\Roaming\SAP\Common, o en la ubicación especificada en una de las variables del Registro anteriores. Si Tableau no puede encontrar el archivo XML en una de las ubicaciones anteriores, esto puede generar información de conexión SAP BW en blanco o incompleta en Tableau Desktop.
Solución
Opción 1
  1. Guarde los archivos SAPUILandscape.xml y SAPUILandscapeGlobal.xml en la siguiente ubicación predeterminada: "C:\Users\<username>\AppData\Roaming\SAP\Common"

Opción 2
  1. Para los archivos SAPUILandscape.xml, compruebe que la ubicación de estos esté especificada en una de las siguientes ubicaciones del Registro (ordenadas según la prioridad en que Tableau verifica cada ubicación):
  • HKEY_CURRENT_USER\Software\SAP\SAPLogon\Options\PathConfigFilesLocal 
  • HKEY_LOCAL_MACHINE\Software\Wow6432Node\SAP\SAPLogon\Options\PathConfigFilesLocal 
NOTA: Si desea actualizar la ubicación de los archivos, abra el cliente de configuración de la GUI de SAP y cambie la ruta de archivo especificada en Opciones de inicio de sesión de SAP > Archivos de configuración local, o bien modifique el Registro de forma manual.


Opción 3 
  1. Realice una copia de seguridad de la configuración actual. Al editar el Registro manualmente, actúe con precaución y consulte al equipo de TI relevante antes de realizar cualquier cambio. También se recomienda encarecidamente hacer una copia de seguridad de la configuración actual antes de hacerlo.
  2. Para los archivos SAPUILandscapeGlobal.xml, compruebe que la ubicación de estos esté especificada en una de las siguientes ubicaciones del Registro (ordenadas según la prioridad en que Tableau verifica cada ubicación):
  • HKEY_CURRENT_USER\Software\SAP\SAPLogon\Options\LandscapeFileOnServer
  • HKEY_LOCAL_MACHINE\...\LandscapeFileOnServer
  • HKEY_LOCAL_MACHINE\...\CoreLandscapeFileOnServer
  • HKEY_CURRENT_USER\...\CoreLandscapeFileOnServer
  • HKEY_CURRENT_USER\...\PathConfigFilesLocal
  • HKEY_LOCAL_MACHINE\...\PathConfigFilesLocal
NOTA: Si desea actualizar la ubicación de los archivos, abra el cliente de configuración de la GUI de SAP y cambie la ruta de archivo especificada en Opciones de inicio de sesión de SAP > Archivos de configuración local, o bien modifique el Registro de forma manual.
Recursos adicionales
  • La carpeta \AppData\Roaming\SAP\Common siempre se verificará después de que se hayan comprobado todas las variables del Registro. 
  • Tome nota del orden en que Tableau verifica las variables del Registro y la carpeta \SAP\Common. La ubicación de mayor prioridad anula a todas las demás.
  • Tenga en cuenta que la variable de entorno SAPLOGON_LSXML_FILE no es compatible con Tableau Desktop.


Número del artículo de conocimiento

001471162

 
Cargando
Salesforce Help | Article