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upgrade-tsm スクリプトでアップグレードが失敗した後のエラー "Unable to login" (ログインできません)

公開日: Aug 24, 2022
説明

アップグレードするときに、次のエラーが発生する場合があります。 

"Unable to login" (ログインできません) および "sun.security.validator.ValidatorException: PKIX path validation failed: java.security.cert.CertPathValidatorException: signature check failed;" (sun.security.validator.ValidatorException: PKIX パス検証に失敗しました: java.security.cert.CertPathValidatorException: 署名チェックに失敗しました;)

Cause

不正な証明書が Windows 証明書ストレージにあります。

解決策
IT チームと協力して以下の手順を実行し、失敗したアップグレードから Tableau Server (Windows OS) をリカバリします。
  1. [コントロール パネル] から、新しい Tableau Server をアンインストールします。
  2. Regedit を実行して、新しいバージョンの Tableau Server へのすべての参照を削除します。これには、エントリとフォルダーの削除、およびエントリの更新 (複数のバージョンの Tableau Server に対する設定である場合) の両方が含まれます (例: HKEY_CURRENT_USER\Software\Tableau\Tableau Server <ビルド番号>)。
  3. "TableauServerManagerCA" に対して (または、この CA によって) 発行されたローカル コンピューター用の証明書を ("MMC" を使用して) 確認します。アップグレードの日付と時刻に基づいて、特定の証明書を探して削除する必要があります。 
  4. ログ ファイル (\Tableau\Tableau Server\logs\app-upgrade.txt) から、一時的な自己署名証明書用の Java キー ストアの場所を特定します。
  5. この .jks ファイル (たとえば、C:\ProgramData\Tableau\Tableau Server\tableauservicesmanagerca.jks) を削除します。
  6. セットアップ インストーラーを実行して、もう一度アップグレードします。
注: このセクションの説明は、レジストリの編集を問題なく行うことができる IT 専門家を対象にしています。
ナレッジ記事番号

001471163

 
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