Loading

Unable to Connect to Databases Using Mutual SSL

Date de publication: Mar 12, 2025
Description

Unable to connect to databases using mutual SSL because the check box "Enable SSL" in some connections does not prompt for client certificate and only does one-way authentication.
 

Cause

This issue occurs because there is no built-in dual authentication for the "Enable SSL" checkbox.
 

Résolution

For ODBC data connections, use a TDC file in order to accomplish the mutual SSL authentication. See an example below for the Presto data source: 
 

<?xml version='1.0' encoding='utf-8' ?>
<connection-customization class='presto' version='2023.1' enabled='true'>
<vendor name='presto' />
<driver name='presto' />
<customizations>
<customization name='odbc-connect-string-extras' value='TRUSTEDCERTS=X:\XXXX.pem'/>
</customizations>
</connection-customization>


If the data source does not require SSL from the client machine, then the Enable SSL checkbox should work without a TDC file. However, please note that in most cases, this is not how the data source is set up and requires the client cert.

For JDBC connectors, a ".properties" file is used to configure SSL.  Remember, if a properties file is used to configure trust and a workbook is published to Tableau Server, both the Tableau Desktop and Tableau Server computers must have copies of the same properties file and truststore.jks file.  Please refer to your specific database/driver configuration guide for further information.  
 

Ressources supplémentaires

Important: Tableau does not test or support TDC files. These files should be used as a tool to explore or occasionally address issues with your data connection. Creating and maintaining TDC files requires careful manual editing, and there is no support for sharing these files.

Example JDBC Connection with SSL for Oracle

 

 

Numéro d’article de la base de connaissances

001471232

 
Chargement
Salesforce Help | Article