Loading

Errore "[Simba][AthenaJDBC](100131) An error has been thrown from the AWS SDK client. Unable to execute HTTP request:Connection Reset" durante la connessione all'origine dati Amazon Athena

Data pubblicazione: Jul 20, 2023
Descrizione
Dopo la connessione ad Amazon Athena da Tableau Desktop, i dati non vengono visualizzati nella finestra di connessione e potrebbero verificarsi i seguenti errori quando si trascina un campo nella vista o si visualizzano i dati: 
 
[Simba][AthenaJDBC](100131) An error has been thrown from the AWS SDK client. Unable to execute HTTP request:Connection Reset ([Simba][AthenaJDBC](100131) È stato generato un errore dal client SDS AWS. Impossibile eseguire la richiesta HTTP: connessione reimpostata)

O

[Simba][AthenaJDBC](100123) An error has occurred. Exception during column initialization: Details: Unable to execute HTTP request:Connect to [Athena us-east-1-amazonaws.com……..] failed: Connection timed out: connect[Execution ID:xxxxxxxx-xxxx...........] ([Simba][AthenaJDBC](100123) Si è verificato un errore. Eccezione durante l'inizializzazione della colonna: Dettagli: Impossibile eseguire la richiesta HTTP: Connessione a [Athena us-east-1-amazonaws.com……..] non riuscita: Timeout connessione: connessione[ID esecuzione:xxxxxxxx-xxxx...........])

Cause

La porta 444 è bloccata. L'accesso alla porta 444 è necessario poiché questa porta viene utilizzata dal servizio Athena per trasmettere i risultati delle query
Risoluzione
Collabora con il tuo team IT per verificare che la comunicazione sulla porta 444 non sia bloccata. 
Risorse aggiuntive
I driver JDBC di Athena successivi alla versione 2.0.2 utilizzano QueryResultStreaming (athena:GetQueryResultsStream) per recuperare i risultati delle query. QueryResultStreaming utilizza una porta in uscita diversa (444) rispetto al solito (443) ed entrambe le porte devono essere aperte. Questo comportamento è documentato nella pagina di rilascio dei driver di Athena.

Numero articolo Knowledge

001471233

 
Caricamento
Salesforce Help | Article