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Azure SQL に接続するときのエラー "既存の接続はリモート ホストによって強制的に閉じられました"

公開日: Aug 24, 2022
説明

Tableau Desktop を Microsoft Azure SQL に接続すると、次のエラーが発生する場合があります。 

[Microsoft][ODBC Driver 13 for SQL Server]TCP Provider: An existing connection was forcibly closed by the remote host. (TCP プロバイダー: 既存の接続はリモート ホストによって強制的に閉じられました。)
[Microsoft][ODBC Driver 13 for SQL Server]Communication link failure (通信リンクの障害)
Unable to connect to the server "
<servername>.database.windows.net". Check that the server is running and that you have access privileges to the requested database. (サーバー "<servername>.database.windows.net" に接続できません。サーバーが実行されており、要求したデータベースに対してアクセス権限を持っていることを確認してください。)

Cause

根本的な原因は、Azure SQL ファイアウォール構成の問題、Azure SQL サービスの停止、名前解決、ファイアウォールまたはプロキシ構成、またはその他のネットワークの問題である可能性があります。
解決策
この問題のトラブルシューティングを行うには、Excel を Azure SQL データベースに接続してレポートを作成するの手順 5 までを実行して、Excel から同じデータベースに接続してみてください。

手順 5 でテーブルまたはビューのリストを取得できない場合は、次の手順に従ってください。
  1. Azure portal にアクセスします。
  2. [SQL servers (SQL サーバー)] をクリックします。 
  3. 対象のサーバーをクリックします。
  4. [設定] > [ファイアウォール] をクリックします。
  5. クライアント IP アドレスを追加します。詳細については、「Azure SQL Database と Azure Synapse IP ファイアウォール規則」を参照してください。
その他のリソース
このトピックの詳細については、SQL Azure 接続トラブルシューティング ガイド (英語) を参照してください。

: 上記の情報は、サードパーティ製品に関連する情報です。サードパーティ コンテンツが正確で最新のものであるように確認する最善の努力を払っていますが、ここに参照される情報は、サードパーティ製品の変更に伴い、予告なしに変わる場合があることにご注意ください。
ナレッジ記事番号

001471264

 
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