Loading

Error "Unable to connect to the Microsoft Access database" o "Database error 0x80040154: Class not registered" al conectarse a Access 365

Fecha de publicación: Aug 24, 2022
Descripción
Al intentar conectarse a Microsoft Access 365, puede aparecer uno de los siguientes errores

"An error occurred while communicating with Microsoft Access. Download and install the drivers and then connect

Unable to connect to the Microsoft Access database
"C:\Users\<username\Filepath\>accdb". Check that the path is correct and that you have access privileges for the requested file." (Se produjo un error al comunicarse con Microsoft Access. Descargue e instale los controladores y conéctese. No se pudo conectar a la base de datos de Microsoft Access en la ruta "C:\Users\<username\Filepath\>accdb").

O

"The drivers required to connect to the data source are not installed. The error may need to be resolved through local configuration changes on the Tableau side. Database error 0x80040154: Class not registered Unable to connect to the Microsoft Access database "<filepath>.accdb". Check that the path is correct and that you have access privileges for the requested file." (No se han instalado los controladores necesarios para conectarse a la fuente de datos. El error debe resolverse mediante cambios en la configuración local por parte de Tableau. Error de la base de datos 0x80040154: No se ha registrado la clase. No es posible conectarse a la base de datos de Microsoft Access ".aacdb". Compruebe que la ruta es correcta y que tiene privilegios de acceso para el archivo solicitado).

Este error se produce después de seleccionar el nombre del archivo en la conexión de Access en Tableau Prep o cuando se intenta crear una conexión en Tableau Desktop a Microsoft Access.

 

Cause

Se ha instalado la versión de 32 bits del controlador de Microsoft Access.
Solución

Opción 1:

  1. Desinstale el controlador del motor de la base de datos de Microsoft Access, que aparece en la lista de Aplicaciones y funciones o Programas y funciones (en Desinstalar un programa). Probablemente se trate de la versión de 32 bits del controlador.
  2. Vaya a la página de controladores de Tableau (http://tableau.com/support/drivers) y, después, a Microsoft Access > Tableau Prep. Aquí se indica que se debe instalar la versión de 64 bits del controlador con Tableau Prep. Las instrucciones son un poco más complejas para Tableau Desktop. 
  3. Haga clic en el enlace de la página de controladores: https://www.microsoft.com/es-es/download/details.aspx?id=13255. Haga clic en el enlace de descarga y seleccione el paquete de descarga que indique "x64". Instale el controlador.
  4. La conexión debería funcionar sin problemas. Es posible que deba cerrar y volver a abrir Tableau Prep o Tableau Desktop para que el cambio surta efecto.

Opción 2:

  1. Si tiene acceso a una versión más reciente de MS Access, cargue el archivo .mdb en la nueva versión de Access.
  2. Seleccione Archivo/Guardar como y guárdelo con el nuevo tipo de archivo (.accdb). 
  3. Cierre MS Access. 
  4. Abra Tableau y cargue el archivo .accdb.

Opción 3:

  1. Abra Tableau Desktop.
  2. Conéctese al archivo .mdb de MS Access.
  3. Cree una extracción de ese archivo .mdb.
  4. Si utiliza Tableau Prep, use la copia local de la extracción como nodo de entrada de Tableau Prep.
Recursos adicionales
Para obtener más información, consulte Error "Los controladores... no se han instalado correctamente".
Número del artículo de conocimiento

001471281

 
Cargando
Salesforce Help | Article