Loading

Wiederherstellen einer TSBAK-Datei schlägt bei 10 % fehl - Wiederherstellungsdienst wird deinstalliert

Veröffentlichungsdatum: Aug 24, 2022
Beschreibung

Wiederherstellen von einer TSBAK-Datei schlägt fehl bei '10 % - Wiederherstellungsdienst wird deinstalliert'. 

Zusätzlich finden Sie folgende Fehlermeldung im Protokoll tabadmincontroller-*.log:

Caused by: com.tableausoftware.tabadmin.util.ZipUtils$UnsupportedTsbakCharsetException: (Ursache: com.tableausoftware.tabadmin.util.ZipUtils$UnsupportedTsbakCharsetException:) Unsupported charset in tsbak file '<PathToBackupFIle.tsbak>'. (Nicht unterstützter Zeichensatz in TSBAK-Datei '<PfadZurWiederherstellungsDatei.tsbak>'.) Recreate using UTF-8. (Erstellen Sie die Datei mit UTF-8 neu.)

Cause

Die TSBAK-Datei wurde mit einer anderen Kodierung als UTF-8 kodiert. 
Lösung
Komprimieren Sie die TSBAK-Datei (ZIP) erneut mit UTF-8. 
  1. Erstellen Sie eine Kopie der TSBAK-Datei, bei der ein Problem bei der Wiederherstellung auftritt. (Das dient dazu, die ursprüngliche Datei zur Sicherheit aufzubewahren.)
  2. Benennen Sie die kopierte TSBAK-Datei in '<Dateiname>.zip' um.
  3. Extrahieren Sie die Datei <Dateiname>.zip mit einem geeigneten Dienstprogramm (Beispiel: 7-zip).
  4. Komprimieren Sie die Datei <Dateiname> mit einem Dienstprogramm und nutzen Sie dabei die UTF-8-Kodierung.
  5. Benennen Sie '<Dateiname>.zip' in '<Dateiname>.tsbak' um. 
    Hinweis: Stellen Sie sicher, dass das Tableau Server-Konto "Als Benutzer ausführen" mindestens über Leseberechtigung für die neue Datei <Dateiname>.tsbak verfügt.
  6. Führen Sie erneut eine Wiederherstellung mit der neu erstellten Datei <Dateiname>.tsbak durch. (Beispiel: tsm maintenance restore -f <Dateiname>.tsbak)  
**Für Schritt 4 können Sie das Dienstprogramm 'Bandzip' nutzen, um die Datei im UTF-8-Format zu speichern**
Nummer des Knowledge-Artikels

001471292

 
Laden
Salesforce Help | Article