Loading

Il ripristino dal file .tsbak non riesce al 10% - Disinstallazione servizi di ripristino in corso

Data pubblicazione: Aug 24, 2022
Descrizione

Il ripristino dal file .tsbak non riesce al "10% - Disinstallazione servizi di ripristino in corso". 

Inoltre, il seguente messaggio di errore viene registrato in tabadmincontroller-*.log.

Caused by: com.tableausoftware.tabadmin.util.ZipUtils$UnsupportedTsbakCharsetException: Unsupported charset in tsbak file '<PathToBackupFIle.tsbak>'. Recreate using UTF-8. (Causato da: com.tableausoftware.tabadmin.util.ZipUtils$UnsupportedTsbakCharsetException: set di caratteri non supportato nel file tsbak "<PercorsoFileDiBackup.tsbak>". Ricrea utilizzando UTF-8.)

Cause

Il file .tsbak è stato codificato con una codifica diversa da UTF-8. 
Risoluzione
Comprimi di nuovo il file .tsbak (.zip) utilizzando UTF-8. 
  1. Crea una copia del file .tsbak che presenta problemi di ripristino. (Questo serve per mantenere il file originale per sicurezza)
  2. Rinomina il file .tsbak copiato come "<NomeFile>.zip".
  3. Decomprimi il file <NomeFile>.zip con un'utilità di decompressione (ad esempio, 7-zip).
  4. Comprimi il file <NomeFile> con un'utilità zip utilizzando la codifica UTF-8.
  5. Rinomina "<NomeFile>.zip" come "<NomeFile>.tsbak". 
    Nota: Assicurati che l'utente Esegui come di Tableau Server abbia almeno l'autorizzazione di lettura per il nuovo file <NomeFile>.tsbak.
  6. Esegui di nuovo il ripristino con il file <NomeFile>.tsbak ricreato. (ad esempio, tsm maintenance restore -f <NomeFile>.tsbak)  
**Per il passaggio 4, puoi utilizzare l'utilità "Bandzip" per eseguire il salvataggio in formato UTF-8**
Numero articolo Knowledge

001471292

 
Caricamento
Salesforce Help | Article