Loading

尝试打开或刷新 OneDrive 上托管的文件时,出现 错误“该文件正在使用中。”

发布日期: Aug 24, 2022
描述

当尝试连接到 OneDrive 上托管的文件时,会出现以下错误:

<文件名>
该文件正在使用中。
请输入新名称或关闭其他程序中打开的文件。


此外,当尝试刷新 OneDrive 上托管的文件时,会出现以下错误:

无法打开文件:“<文件路径>”:此进程无法访问该文件,因为它正被另一个进程使用。

 

Cause

文件在 Excel 中打开,同时 Tableau Desktop 也打开。当选择“使用 Office 2016 同步我打开的 Office 文件”设置并且文件在 Excel 中打开时,OneDrive 会锁定其他程序的读取权限。
解决方案

选项 1

确保在打开 Tableau Desktop 的同时,没有来自 OneDrive 的文件在 Microsoft Excel 中打开。

选项 2

请与您的 IT 团队合作,编辑 OneDrive 设置,以不同步文件。
  1. 右键单击 OneDrive 名称(Windows 文件查找器的左窗格),然后选择“设置”。
  2. 导航到 Office 选项卡。
  3. 取消选择“使用 Office 2016 同步我打开的 Office 文件”选项
  4. 单击“确定”。
  5. 关闭所有打开的 Excel 文件,然后重新打开以使更改生效。
其他资源
有关 OneDrive 中“使用 Office 2016同步我打开的 Office 文件”设置的其他信息,请参阅以下 Microsoft 文章:使用 Office 2016 同步我打开的 Office 文件
知识文章编号

001471458

 
正在加载
Salesforce Help | Article