Loading

Errores "systemd is not running" o "systemd unit user@<id> is not running" al inicializar TSM

Fecha de publicación: Jul 20, 2023
Descripción
Cuando intenta aceptar el EULA e inicializar TSM, aparecen mensajes de error similares a los siguientes:
 
 "systemd is not running" (systemd no se está ejecutando)
 "Could not connect to TSM Controller at  <TableauServer>:8850" (No se ha podido conectar al controlador TSM en <TableauServer>:8850)

 
Al ejecutar el script "migrate-to-single-user", aparece el siguiente mensaje de error: systemd unit user@<id> is not running (la unidad de systemd user@<id> no se está ejecutando).
Al intentar comprobar si Tableau Services está habilitado, aparecen mensajes de error como "system unit not found" (unidad de sistema no encontrada).
  1. Inicie sesión en la cuenta de usuario del sistema.
    sudo su -l tableau
  2. Compruebe si los servicios están habilitados (si la variable de entorno no se ha establecido, podrían aparecer mensajes de error como "system unit not found" [unidad de sistema no encontrada]).
    systemctl --user list-unit-files

Cause

La variable de entorno "XDG_RUNTIME_DIR" no está establecida para el usuario de sistema. Por ello, Systemd no pudo ejecutarse como un servicio de usuario. Esto puede causar que Tableau Services no se ejecute y que no se utilicen comandos TSM.
Solución
  1. Asegúrese de que el usuario "tableau" tiene los permisos adecuados. 
  2. Colabore con su equipo de TI para asegurarse de que la variable de entorno "XDG_RUNTIME_DIR" está establecida correctamente para el usuario de sistema. 
       
 
Número del artículo de conocimiento

001471492

 
Cargando
Salesforce Help | Article