Loading

Erreurs « ​systemd is not running » ou « ​systemd unit user@<id> is not running » lors de l'initialisation de TSM

Date de publication: Jul 20, 2023
Description
Lorsque vous tentez d'accepter le contrat de licence de l'utilisateur final et d'initialiser TSM, des messages d'erreur du type suivant s'affichent :
 
 "systemd is not running" (systemid n'est pas en cours d'exécution)
 "Could not connect to TSM Controller at  <TableauServer>:8850" (Impossible de se connecter au Contrôleur TSM à l'adresse...)

 
Lorsque vous exécutez le script « migrate-to-single-user », l'erreur suivante apparaît : systemd unit user@<id> is not running
Vérifiez si les services Tableau sont activés (si la variable d'environnement n'est pas définie, des messages d'erreur du type « system unit not found » (unité système introuvable) risquent de s'afficher.
  1. Connectez-vous au compte utilisateur système
    sudo su -l tableau
  2. Vérifiez si les services sont activés (si la variable d'environnement n'est pas définie, des messages d'erreur du type « system unit not found » (unité système introuvable) risquent de s'afficher.
    systemctl --user list-unit-files

Cause

La variable d'environnement « XDG_RUNTIME_DIR » n'a pas été définie pour l'utilisateur système. De ce fait, Systemd n'a pas pu être utilisé comme service utilisateur. Ceci peut empêcher les services Tableau Services de s'exécuter et empêcher l'utilisation des commandes TSM.
Résolution
  1. Vérifiez que l'utilisateur « tableau » dispose des autorisations appropriées.
  2. Adressez-vous à votre département informatique pour être sûr que la variable d'environnement « XDG_RUNTIME_DIR » est correctement définie pour l'utilisateur système.
       
 
Numéro d’article de la base de connaissances

001471492

 
Chargement
Salesforce Help | Article