Loading

TSM 初期化時のエラー "systemd is not running" または "systemd unit user@<id> is not running"

公開日: Jul 20, 2023
説明
EULA に同意して TSM を初期化しようとすると、次のようなエラー メッセージが表示されます。
 
 "systemd is not running " ("システムが稼働していません")
 "Could not connect to TSM Controller at  <TableauServer>:8850" ("<TableauServer>:8850 で TSM コントローラーに接続できませんでした")

 
スクリプト "migrate-to-single-user" を実行する際に、次のエラーが表示されます。"systemd unit user@<id> is not running" ("systemd ユニット ユーザー @<id> が稼働していません")
Tableau サービスが有効になっているかどうかを確認しようとすると、"system unit not found" ("システム ユニットが見つかりません") のようなエラー メッセージが表示されます。
  1. システム ユーザー アカウントにサインインします
    sudo su -l tableau
  2. サービスが有効になっているかどうかを確認します (環境変数が設定されていない場合、"system unit not found" ("システム ユニットが見つかりません") のようなエラー メッセージが表示される場合があります)
    systemctl --user list-unit-files

Cause

システム ユーザーの環境変数 "XDG_RUNTIME_DIR" が設定されていませんでした。その結果、Systemd をユーザー サービスとして実行できませんでした。それにより、Tableau サービスを実行できず、TSM コマンドを使用できない可能性があります。
解決策
  1. 'tableau' ユーザーが適切なパーミッションを持っていることを確認します。
  2. IT チームと連携して、システム ユーザーの環境変数 "XDG_RUNTIME_DIR" が正しく設定されていることを確認します。
       
 
ナレッジ記事番号

001471492

 
読み込み中
Salesforce Help | Article