Loading

Errors "systemd is not running" or "systemd unit user@<id> is not running" initializing TSM

Publiseringsdato: Apr 25, 2025
Beskrivelse
When you try to accept the EULA and initialize TSM, error messages similar to the following appear:
 
 "systemd is not running"
 "
systemd unit user@996 is not running. Check /var/log/messages or /var/log/syslog."
 "Could not connect to TSM Controller at  <TableauServer>:8850"
 
When running the script "migrate-to-single-user", the following error appears : systemd unit user@<id> is not running
When attempting to verify if Tableau Services are enabled you receive error messages like "system unit not found" 
  1. Sign into the system user account
    sudo su -l tableau
  2. Verify if services are enabled (if the environment variable is not set you may receive error messages like "system unit not found")
    systemctl --user list-unit-files
  3. If XDG_RUNTIME_DIR is set for the appropriate user, verify that the pam_systemd.so module is included in the /etc/pam.d/system-auth configuration file.

Cause

The environment variable "XDG_RUNTIME_DIR" was not set for the System User. As a result Systemd could not be run as a user service. This can prevent Tableau Services from being able to be run, and prevent TSM commands from being used.

The pam_systemd.so module is required to initialize the XDG_RUNTIME_DIR and if not available, may result in errors setting the environment variable.
Løsning
  1. Ensure that the 'tableau' user has the appropriate permissions. 
  2. Work with your IT to ensure that the environment variable "XDG_RUNTIME_DIR" is set correctly for the System User. 
  3. Check the /etc/pam.d/system-auth file and make sure the following line exists: -session optional pam_systemd.so
 
 
Flere ressurser

Knowledge-artikkelnummer

001471492

 
Laster
Salesforce Help | Article