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Error "The Hyper file is corrupt and needs to be re-created"When Viewing a Published Workbook

Publiceringsdatum: Apr 13, 2024
Beskrivning
When viewing a published view or workbook on Tableau Cloud, the following error might occur:

“Unable to connect to the data source.
Try connecting again. If the problem persists, disconnet from the data source and contact the data source owner
(...)The Hyper file is corrupt and needs to be re-created”.

Cause

This error is shown whenever the current extract data differs from the last time the extract was created or refreshed. Such differences may occur due to a variety of reasons, such as problems with unreliable hard disks, thumb drives or network transfers (e.g., when publishing to Tableau Cloud).
Lösning
The extracts used by that view or workbook need to be re-created. Please follow one of the two options below

Option 1 - Issue a full refresh on Tableau Cloud

If possible, try to issue a full refresh of the extracts by following this steps:
  1. Navigate to the published workbook (or published data-source) on Tableau Cloud and click on the “…” button (called More actions) located next to the Download icon.
  2. From the drop-down menu, select Refresh Extracts… to issue a refresh

Option 2 - Locally re-creating the extract and re-publishing the workbook to Tableau Cloud

Alternatively, the error can be resolved by re-creating the extracts locally:
  1. Download and open the workbook in Tableau Desktop
  2. Re-create the extract on Tableau Desktop by selecting Data > (Extract Name) > Extract Data from the menu, and selecting Extract on the dialog showing up.
  3. Re-publish the workbook (or data-source) to Tableau Cloud.
Ytterligare resurser
While such errors are only detected for extracts created by Tableau versions 10.5 or later, re-creating the extracts on any version of Tableau should resolve the error.
Knowledge-artikelnummer

001471514

 
Laddar
Salesforce Help | Article