Loading

Snowflake-Kennzahlen werden in der Ansicht nicht angezeigt

Veröffentlichungsdatum: Oct 17, 2023
Beschreibung
Wenn einer Ansicht in Tableau Desktop einige Kennzahlen aus einer Snowflake-Datenquelle hinzugefügt werden, werden die Werte für diese Kennzahlen möglicherweise nicht angezeigt. Für die zugrunde liegenden Daten werden möglicherweise Werte angezeigt, oder es wird möglicherweise Null angezeigt.

Cause

verwendet doppelte Anführungszeichen für Bezeichner in den zugrundeliegenden SQL-Abfragen, was bedeutet, dass wir anfängliche bei Feldnamen zwischen Groß- und Kleinschreibung unterschieden haben. Zum Beispiel "FieldName"

Falls QUOTED_IDENTIFIERS_IGNORE_CASE auf TRUE eingestellt ist, dann geben zusätzliche Abfragen der Snowflake-Datenbanken die Feldnamen in Großbuchstaben zurück, zum Beispiel "FIELDNAME". Da die Sitzungsparameter die anfänglichen Metadaten-Sammlung nicht beeinflusst, resultiert dies in einer Unstimmigkeit.
 
Lösung

Option 1

  1. Öffnen Sie die betreffende Arbeitsmappe in Tableau Desktop. 
  2. Wählen Sie die Registerkarte Datenquelle aus.
  3. Klicken Sie im linken Bereich mit der rechten Maustaste auf die Snowflake-Verbindung und wählen Sie SQL-Anfangsdaten... aus.
  4. Geben Sie im Dialogfeld SQL-Anfangsdaten die folgende Anweisung ein:
    ALTER SESSION SET QUOTED_IDENTIFIERS_IGNORE_CASE = FALSE
  5. Klicken Sie auf OK.

Option 2

Alternativ können Sie zusammen mit Ihrem Snowflake-Administrator den Parameter QUOTED_IDENTIFIERS_IGNORE_CASE für die Datenquelle global auf FALSE festlegen.
Zusätzliche Ressourcen

Hinweise zu Option 1:

Einige Snowflake-Datenbank erfordern, dass Variable am Start einer Sitzung eingestellt werden.Falls das Editieren der bestehenden Verbindung, damit die SQL-Anfangsdaten eingeschlossen sind, das Problem nicht lösen, tun Sie dann folgendes in der betroffenen Arbeitsmappe:
  1. Erstellen Sie eine neue Verbindung zur selben Snowflake-Datenquelle
  2. Klicken Sie im ersten Verbindungsdialog auf SQL-Anfangsdaten...
  3. Geben Sie im Dialogfeld SQL-Anfangsdaten die folgende Anweisung ein:
    ALTER SESSION SET QUOTED_IDENTIFIERS_IGNORE_CASE = FALSE
  4. Verbinden Sie in der Registerkarte Datenquelle wie normal zu den Snowflake-Tabellen
  5. Navigieren Sie zu einem Arbeitsblatt.
  6. Navigieren Sie zu Daten > Datenquelle ersetzen...
  7. Ersetzen Sie die ursprüngliche Datenquelle durch die neue Datenquelle

Nummer des Knowledge-Artikels

001471529

 
Laden
Salesforce Help | Article