Loading

Las medidas de Snowflake no aparecen en la vista

Fecha de publicación: Oct 17, 2023
Descripción
Cuando se añaden algunas medidas desde una fuente de datos Snowflake a una vista en Tableau Desktop, los valores de estas medidas podrían no aparecer. Los datos subyacentes pueden mostrar valores o Null.

Cause

Tableau usa comillas dobles para los identificadores de las consultas de SQL subyacentes, lo que significa que se distingue entre mayúsculas y minúsculas para los nombres de campos: "NombreDeCampo"

Si QUOTED_IDENTIFIERS_IGNORE_CASE tiene el valor TRUE, las consultas adicionales realizadas a la base de datos de Snowflake devolverán los nombres de los campos en mayúsculas, por ejemplo, "NOMBREDECAMPO". Como el parámetro de la sesión no afecta a la recopilación inicial de metadatos, esto creará una discordancia.
 
Solución

Opción 1

  1. Abra el libro de trabajo afectado en Tableau Desktop.
  2. Seleccione la pestaña Fuente de datos.
  3. Haga clic con el botón derecho en la conexión Snowflake del panel izquierdo y seleccione SQL inicial.
  4. En el cuadro de diálogo SQL inicial, escriba la instrucción siguiente:
    ALTER SESSION SET QUOTED_IDENTIFIERS_IGNORE_CASE = FALSE
  5. Haga clic en Aceptar.

Opción 2

Como alternativa, hable con su administrador de Snowflake para establecer el parámetro QUOTED_IDENTIFIERS_IGNORE_CASE como FALSE globalmente en la fuente de datos.
Recursos adicionales

Notas sobre la opción 1:

Algunas bases de datos Snowflake requieren que las variables se configuren al comienzo de una sesión. Si al editar la conexión actual para incluir el SQL inicial no se resuelve el problema, siga estos pasos para el libro de trabajo afectado:
  1. Cree una nueva conexión en la misma base de datos de Snowflake
  2. En el el primer cuadro de diálogo de conexión, haga clic en SQL inicial...
  3. En el cuadro de diálogo SQL inicial, escriba la instrucción siguiente:
    ALTER SESSION SET QUOTED_IDENTIFIERS_IGNORE_CASE = FALSE
  4. En la pestaña Fuente de datos, conéctese a las tablas de Snowflake
  5. Vaya a una hoja de trabajo
  6. Vaya a Datos > Reemplazar fuente de datos...
  7. Reemplace la fuente de datos original con la nueva fuente de datos

Número del artículo de conocimiento

001471529

 
Cargando
Salesforce Help | Article