Loading

Les mesures Snowflake n'apparaissent pas dans la vue

Date de publication: Oct 17, 2023
Description
Lorsque certaines mesures provenant d'une source de données Snowflake sont ajoutées à une vue dans Tableau Desktop, il se peut que les valeurs pour ces mesures ne s'affichent pas. Les données sous-jacente peuvent afficher des valeurs ou peuvent afficher Null.

Cause

Tableau utilise des guillemets doubles pour les identificateurs dans les requêtes SQL sous-jacentes, ce qui signifie que nous stockons initialement des noms de champ en respectant la casse, par exemple « NomChamp »

Si QUOTED_IDENTIFIERS_IGNORE_CASE est défini sur TRUE, les requêtes supplémentaires envoyées à la base de données Snowflake renverront les noms de champs entièrement en majuscules, par exemple « FIELDNAME ». Étant donné que le paramètre de session n'affecte pas la collecte des métadonnées initiales, il en résulte une non-correspondance.
 
Résolution

Option 1

  1. Ouvrez le classeur affecté dans Tableau Desktop.
  2. Sélectionnez l'onglet Source de données.
  3. Faites un clic droit sur la connexion Snowflake dans le volet gauche et sélectionnez SQL initial....
  4. Dans la boîte de dialogue SQL initial, entrez l'instruction suivante :
    ALTER SESSION SET QUOTED_IDENTIFIERS_IGNORE_CASE = FALSE
  5. Cliquez sur OK.

Option 2

Sinon, adressez-vous à votre administrateur Snowflake pour définir le paramètre QUOTED_IDENTIFIERS_IGNORE_CASE sur FALSE globalement pour la source de données.
Ressources supplémentaires

Remarque sur l'Option 1 :

Certaines bases de données Snowflake nécessitent que les variables soient définies au début d'une session. Si la modification de la connexion existante de manière à inclure SQL initial ne résout pas le problème, procédez comme suit dans le classeur concerné :
  1. Créez une nouvelle connexion à la même base de données Snowflake
  2. Dans la première boîte de dialogue de la première connexion, cliquez sur SQL initial...
  3. Dans la boîte de dialogue SQL initial, entrez l'instruction suivante :
    ALTER SESSION SET QUOTED_IDENTIFIERS_IGNORE_CASE = FALSE
  4. Dans l'onglet Source de données, connectez-vous aux tables Snowflake comme d'habitude
  5. Accédez à une feuille de calcul
  6. Accédez à Données > Remplacer la source de données...
  7. Remplacez la source de données d'origine par la nouvelle source de donnée.

Numéro d’article de la base de connaissances

001471529

 
Chargement
Salesforce Help | Article