Loading

El servicio de puerta de enlace no se inicia y Tableau Server se degrada

Fecha de publicación: Mar 6, 2024
Descripción
El servicio de puerta de enlace no se inicia y Tableau Server se degrada.  El problema puede aparecer después de que se reinicia Tableau Server o por un tiempo de inactividad inesperado.

 Al ejecutar el comando, "tsm status -v", el resultado incluye lo siguiente:
Status: DEGRADED (Estado: DEGRADADO) 
'Tableau Server Gateway 0' is in an error state. 
(Error en el estado de la puerta de enlace 0 de Tableau Server)
 
Los registros de la puerta de enlace pueden presentar un problema en el puerto 80 o 443, como el siguiente:

(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions.  : AH00072: make_sock: could not bind to address [::]:443 (Se intentó acceder a un socket de una manera prohibida por los permisos de acceso.  : AH00072: make_sock: no se pudo conectar a la dirección [::]:443)

(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions.  : AH00072: make_sock: could not bind to address [::]:80
(Se intentó acceder a un socket de una manera prohibida por los permisos de acceso.  : AH00072: make_sock: no se pudo conectar a la dirección [::]:80

 

Cause

Este problema tiene varias causas raíz, entre ellas:
  • Debido a un tiempo de inactividad inesperado de Tableau Server, el archivo httpd.pid file, que se suele eliminar o apagar, no se eliminó.
  • Se reinició Tableau Server o se realizó un mantenimiento de Windows que activaron automáticamente el uso de IIS del puerto 80 o 443 con SSL.
  • Otro proceso está ocupando el puerto 80.

 
Solución

Opción 1

Si hubo un tiempo de espera inesperado en el servidor, el archivo httpd.pid puede existir cuando generalmente está eliminado o desactivado.  Revise la siguiente información para determinar si esta opción corresponde.

Compruebe el archivo startup.log en httpd y busque el siguiente elemento del registro:
httpd (pid <number>) ya se está ejecutando

Aunque el proceso de la puerta de enlace no esté en ejecución, hay un archivo httpd.pid en <tableau_server_data_directory>/tabsvc/logs/httpd/ 

Nota: Es posible comprobar las variables del entorno para buscar la ubicación correcta de la carpeta tabsvc/logs/httpd, como $TABLEAU_SERVER_DATA_DIR y $TABLEAU_SERVER_DATA_DIR_VERSION.

Lleve a cabo los pasos siguientes:
  1. Detenga el servidor usando TSM stop.
  2. Linux: busque el archivo httpd.pid en <tableau_server_data_directory>/tabsvc/logs/httpd/ 
    Windows: busque el archivo httpd.pid en <tableau_server_data_directory>\tabsvc\logs\httpd
  3. Elimine manualmente el archivo httpd.pid. 
  4. Ejecute TSM start para iniciar Tableau Server y use "tsm status -v -u <username>" para confirmar que el servicio de la puerta de enlace está en funcionamiento.

Opción 2

Hay un problema de conflicto con los puertos.

Dado que IIS y el servicio de la puerta de enlace de Tableau Server pueden ocupar, ambos, el puerto 80 después de una actualización o un reinicio de Windows, deberá quitar IIS del equipo donde se encuentra Tableau Server, o bien reasignar los puertos.  El comando "netstat -anob" puede ejecutarse para ver los puertos que están en uso actualmente y qué PID está conectado al puerto 80.  Un PID 4 suele ser de IIS.

Para obtener más información sobre los errores a causa de otros servicios en ejecución en el puerto 80, consulte este artículo.

Si se habilitó SSL, el proceso de la puerta de enlace puede presentar un error cuando el puerto 443 está ocupado por otro proceso.
 
Recursos adicionales
Consulte la Ayuda de Tableau Online sobre el método correcto para detener e iniciar Tableau Server.

Puertos de Tableau Services Manager

Información sobre la asignación de puertos para el proceso de puerta de enlace: Proceso de puerta de enlace de Tableau Server

Cambiar el puerto de la puerta de enlace de 80 a otro
Número del artículo de conocimiento

001471551

 
Cargando
Salesforce Help | Article