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Le service de passerelle ne démarre pas et l'état de Tableau Server est dégradé

Date de publication: Mar 6, 2024
Description
Le service de passerelle ne démarre pas et l'état de Tableau Server est dégradé.  Ce problème peut apparaître après un redémarrage de Tableau Server ou suite à une panne inattendue.

 Au moment d'émettre la commande « tsm status -v », la sortie comprend ce qui suit :
Status: DEGRADED (État : DÉGRADÉ) 
'Tableau Server Gateway 0' is in an error state (Passerelle 0 Tableau Server est dans un état d'erreur). 
 
Les journaux de passerelle affichent un des problèmes suivants sur les ports 80 ou 443 :

(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions.  : AH00072: make_sock: could not bind to address [::]:443 (Tentative d'accès à un socket interdite par ses autorisations d'accès : AH00072: make_sock: liaison impossible avec l'adresse [::]:443)

(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions.  : AH00072: make_sock: could not bind to address [::]:80 (Tentative d'accès à un socket interdite par ses autorisations d'accès.  : AH00072: make_sock: liaison impossible avec l'adresse [::]:80)

 

Cause

Ce problème peut avoir plusieurs causes, parmi lesquelles :
  • En raison d'une panne inattendue Tableau Server, le fichier httpd.pid, qui est généralement supprimé lors de l'arrêt, n'a pas été supprimé.
  • Tableau Server a été redémarré ou une maintenance Windows a été effectuée, qui a activé automatiquement l'utilisation par ISS du port 80 ou 443 avec SSL.
  • Le port 80 est pris par un autre processus.

 
Résolution

Option 1

Si le serveur subit une panne inattendue, le fichier httpd.pid peut exister, alors qu'il est normalement supprimé au moment de l'arrêt.  Veuillez consulter les informations suivantes pour déterminer si cette option est applicable.

Recherchez l'élément de journal suivant dans startup.log de httpd :
httpd (pid <number>) already running

Bien que le processus de passerelle ne soit pas en cours d'exécution, un fichier httpd.pid se trouve dans <tableau_server_data_directory>/tabsvc/logs/httpd/ 

Remarque : vous pouvez vérifier les variables d'environnement afin de trouver le bon emplacement du dossier tabsvc/logs/httpd, comme $TABLEAU_SERVER_DATA_DIR et $TABLEAU_SERVER_DATA_DIR_VERSION.

Effectuez ce qui suit :
  1. Arrêtez le serveur à l'aide de TSM stop.
  2. Linux :  localisez le fichier httpd.pid dans <tableau_server_data_directory>/tabsvc/logs/httpd/ 
    Windows :  localisez le fichier httpd.pid dans <tableau_server_data_directory>\tabsvc\logs\httpd
  3. Supprimez manuellement le fichier httpd.pid. 
  4. Exécutez TSM start pour démarrer Tableau Server et utilisez « tsm status -v -u <username> » pour vérifier que le service de passerelle est en cours d'exécution.

Option 2

Il y a un problème de conflit sur un port.

Étant donné que ISS et le service de passerelle de Tableau Server peuvent tous deux occuper le port 80 après un redémarrage ou une mise à jour de Windows, retirez ISS de l'ordinateur Tableau Server ou réassignez les ports.  La commande « netstat -anob » peut être exécutée pour voir les ports en cours d'utilisation et quel PID est lié au port 80.  Un PID de 4 correspond en général à IIS.

Pour plus d'informations sur les erreurs dues à d'autres services qui s'exécutent sur le port 80, veuillez consulter cet autre article.

Si SSL est activé, le processus de passerelle peut être à l'état d'erreur lorsque le port 443 est occupé par un autre processus.
 
Ressources supplémentaires
Consultez l'aide en ligne Tableau qui présente la bonne méthode pour arrêter et démarrer Tableau Server.

Ports Tableau Services Manager

Informations sur l'affectation de ports du processus de passerelle : Processus de passerelle Tableau Server

Modification du port de passerelle défini par défaut sur 80
Numéro d’article de la base de connaissances

001471551

 
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