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Il servizio gateway non viene avviato e Tableau Server risulta danneggiato

Data pubblicazione: Mar 6, 2024
Descrizione
Il servizio gateway non viene avviato e Tableau Server risulta danneggiato.  Questo problema può verificarsi dopo un riavvio di Tableau Server o a causa di un'interruzione imprevista.

 Quando si esegue il comando, "tsm status -v", l'output include quanto segue:
Status: DEGRADED 
'Tableau Server Gateway 0' is in an error state.
(Stato: DANNEGGIATO "Gateway Tableau Server 0" in stato di errore.)
 
I log del gateway possono indicare un problema con la porta 80 o 443, come segue:

(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions.  : AH00072: make_sock: could not bind to address [::]:443 ((OS 10013)È stato eseguito un tentativo di accedere a un socket in un modo vietato dalle relative autorizzazioni di accesso.  : AH00072: make_sock: impossibile effettuare associazioni all'indirizzo [::]:443)

(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions.  : AH00072: make_sock: could not bind to address [::]:80
((OS 10013)È stato eseguito un tentativo di accedere a un socket in un modo vietato dalle relative autorizzazioni di accesso.  : AH00072: make_sock: impossibile effettuare associazioni all'indirizzo [::]:80)

 

Cause

Sono svariate le cause principali di questo problema, ad esempio:
  • A causa di tempi di inattività imprevisti di Tableau Server, il file httpd.pid, che viene in genere rimosso all'arresto, non è stato rimosso.
  • Tableau Server è stato riavviato oppure è stata eseguita una manutenzione di Windows che ha attivato automaticamente IIS usando la porta 80 o 443 con SSL.
  • La porta 80 è occupata da un altro processo.

 
Risoluzione

Opzione 1

Se si è verificata un'interruzione imprevista del Server, può esserci il file httpd.pid quando normalmente viene rimosso all'arresto.  Rivedi le seguenti informazioni per determinare se questa opzione è applicabile.

Controlla se è presente questa voce del log nel file startup.log in httpd:
httpd (pid <number>) already running

Benché il processo di gateway non sia in esecuzione, è presente un httpd.pid in <tableau_server_data_directory>/tabsvc/logs/httpd/ 

Nota: è possibile controllare le variabili di ambiente per trovare la posizione corretta della cartella tabsvc/logs/httpd, quali $TABLEAU_SERVER_DATA_DIR e $TABLEAU_SERVER_DATA_DIR_VERSION.

Segui la procedura indicata di seguito:
  1. Arresta il server utilizzando TSM stop.
  2. Linux: individua httpd.pid in <tableau_server_data_directory>/tabsvc/logs/httpd/ 
    Windows: individua httpd.pid in <tableau_server_data_directory>\tabsvc\logs\httpd
  3. Rimuovi manualmente il file httpd.pid. 
  4. Esegui TSM start per avviare Tableau Server e utilizza "tsm status -v -u <nomeutente>" per verificare che il servizio gateway sia attivo e in esecuzione.

Opzione 2

È presente un problema di conflitto tra le porte.

Poiché IIS e il servizio gateway di Tableau Server possono occupare entrambi la porta 80 dopo un riavvio o un aggiornamento di Windows, rimuovi IIS dalla macchina Tableau Server o riassegna le porte.  È possibile eseguire il comando "netstat -anob" per vedere le porte attualmente in uso e quale PID è associato alla porta 80.  Un PID di 4 solitamente è IIS.

Per ulteriori informazioni sugli errori dovuti ad altri servizi in esecuzione sulla porta 80, consulta questo articolo.

Se SSL è abilitato, il processo di gateway può trovarsi in stato di errore quando la porta 443 è occupato da un altro processo.
 
Risorse aggiuntive
Consulta la Guida online di Tableau circa il metodo corretto per interrompere e avviare Tableau Server.

Porte di Tableau Services Manager

Informazioni sull'assegnazione della porta per il processo di gateway: Processo di gateway di Tableau Server

Modificare la porta 80 del gateway predefinita
Numero articolo Knowledge

001471551

 
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