Loading

Tableau Server のアクティブ化時のエラー "The specified product key was not found (指定されたプロダクト キーが見つかりません)"

公開日: Nov 30, 2023
説明
Tableau Server をアクティブ化しようとすると、次のエラーが発生する場合があります。 
 
The specified product key was not found (指定されたプロダクト キーが見つかりません)
 
tsm licenses activate によって Tableau Server をアクティブ化しようとすると、コマンド プロンプトに以下のエラーが表示される場合があります。
 
ライセンス発行エラー: The specified product key was not found (指定されたプロダクト キーが見つかりません)
 
tsm licenses activate の使用後、tsm.log で以下のエラーが発生する場合があります。
 
An error occurred: 404500, Licensing Error

Cause

考えられる原因は以下のとおりです。
  • プロダクト キーに関するエラー。
  • ライセンス処理で Tableau Server コンポーネントとの通信ができていない。
  • ライセンス データが破損している。
  • プロダクト キーの構成が Server の ATR サービスに受け入れられない。
  • プロダクト キーはライセンス データ ファイルで既にアクティブ化され保存されていますが、Tableau Server では読み込まれていません。
  • Tableau ライセンス サーバーとの通信中のプロキシの問題。 このトピックの詳細については、次の資料を参照してください。
解決策
次の手順に従ってください。
  1. ATR アクティブ化方式を使用していない場合、Flexnet Service を再起動します。詳細については、「Tableau Service 設定の確認」を参照してください。
  2. ATR アクティブ化方式を使用していない場合、「Tableau Service 設定の確認」の説明に従って、Tableau Server ライセンス マネージャーを再起動します。
  3. Server キーに入力ミスがないことを確認します。キーはダッシュも含め、Tableau カスタマー ポータルで表示されるとおりに入力します。
Tableau Server キーが無効になっていて新しいキーと置き換えられていた場合、Tableau カスタマー ポータルで正しいキーがアクティブ化されていることを確認します。

tsm licenses activate を再び試したときに以下のエラーが tsm.log で発生する場合、ライセンスは正しくアクティブ化されている可能性があります。  次の情報は、ATR 以外のアクティブ化のみに適用されます。
 
An error occurred: 400502, Licensing Error
 
この場合は、以下の手順を実行して Tableau Server (TSM プロセスを含む) を再起動してから、もう一度ライセンスを検証します。
1. tsm stop
2. TSM プロセスを再起動します。
Windows:
デフォルトでは次のとおりです。
cd C:\Program Files\Tableau\Tableau Server\packages\scripts.<build_number>
stop-administrative-services start-administrative-services
Linux:
.
sudo /opt/tableau/tableau_server/packages/scripts.<build_number>/stop-administrative-services

sudo /opt/tableau/tableau_server/packages/scripts.<build_number>/start-administrative-services
3. ライセンスが正しくアクティブ化されていることを確認します。
 
tsm licenses list

serveractutil -view
4. tsm start
その他のリソース
上記の手順で問題が解決しない場合は、Tableau テクニカル サポートに連絡し、以下のものを提供してください。
  1. エラーのスクリーンショットと使用しているプロダクト キー
  2. 使用したアクティブ化方式のタイプ (サーバー ATR か、それとも ATR 以外か)
  3. Tableau Server ライセンス データ。「Tableau サポートへのライセンス データの提供」を参照してください。  ATR アクティブ化方式を使用している場合、ATRDIAG の出力が必要になります。  
詳細については、以下を参照してください。

この記事についてディスカッションする...フィードバック フォーラム
ナレッジ記事番号

001471569

 
読み込み中
Salesforce Help | Article