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Error "The specified product key was not found" Activating Tableau Server

Дата публикации: Feb 13, 2025
Описание
When trying to activate Tableau Server, the following error might occur: 
 
The specified product key was not found
 
When trying to activate Tableau Server by tsm licenses activate, the following error might occur in command prompt:
 
Licensing Error: The specified product key was not found.
 
After using tsm licenses activate, the following error might occur in tsm.log:
 
An error occurred: 404502, Licensing Error

Cause

Possible  causes:
  • Error with the product key.
  • License processes not communicating with Tableau Server components.
  • License data is corrupt.
  • Server ATR Service not accepting the product key configuration.
  • Product key is already activated and stored in the License Data file but not being read by Tableau Server.
  • Proxy issue communicating with the Tableau License Server. For more information on this topic, see:
Решение
Follow the steps below:
  1. If not using the ATR activation method, restart Flexnet Service. For more information, see Verify Tableau Service Settings.
  2. If not using the ATR activation method, restart Tableau Server License Manager as described in Verify Tableau Service Settings.
  3. Check that there are no typos in the Server key; Enter the key, including dashes, as the key appears in the Tableau Customer Portal.
If it is found that the Tableau Server key is no longer valid and has been replaced by a new key, visit the Tableau Customer Portal to verify the correct key to be activated.

If the following error occurs in tsm.log when trying tsm licenses activate again, the license may have been successfully activated.  The following information will apply to non-ATR activations only:
 
An error occurred: 400502, Licensing Error
 
In this case, follow the steps below to restart Tableau Server including TSM processes then verify the license again.
1. tsm stop
2. Restart TSM processes
Windows:
By default:
cd C:\Program Files\Tableau\Tableau Server\packages\scripts.<build_number>
stop-administrative-services start-administrative-services
Linux:
.
sudo /opt/tableau/tableau_server/packages/scripts.<build_number>/stop-administrative-services

sudo /opt/tableau/tableau_server/packages/scripts.<build_number>/start-administrative-services
3. Verify that the license has been successfully activated.
 
tsm licenses list

serveractutil -view
4. tsm start
Дополнительные ресурсы
If the above steps do not resolve the issue, please contact Tableau Technical Support and provide the following:
  1. Screenshot of the error and product key being used.
  2. What type of activation method was used, Server ATR or non-ATR?
  3. Tableau Server license data. See Providing License Data to Tableau Support.  Please note if using the ATR activation method, the ATRDIAG output will be needed.  
For more information, see:

 
Номер статьи базы знаний

001471569

 
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Salesforce Help | Article