Loading

Nach dem Neustart werden die Arbeitsknoten nicht angezeigt und keine Registrierungsdatei gefunden.

Veröffentlichungsdatum: Aug 24, 2022
Beschreibung
Der Kunde hat Windows Server neu gestartet und die Tableau Server-Prozesse sind fehlgeschlagen. Im Statusbereich werden alle Lizenzdienste auf den Knoten als fehlgeschlagen angezeigt.

Cause

Dieser Fehler ist allgemeiner Natur und kann auf verschiedene Ursachen zurückzuführen sein.
Die lizenzierten Dienste konnten nicht geladen werden, weil die Knoten nicht ordnungsgemäß registriert waren. (INFO – com.tableausoftware.config.ServiceRegistrationInfoFile zeigt keine gefundene Registrierungsdatei.)
Das Problem tritt auf, wenn die Firewall den Lizenzserververkehr zwischen Windows-Servern blockiert. 

Lösung
  1. Die Lösung besteht darin, sicherzustellen, dass die Firewall den Datenverkehr zu Tableau Server nicht blockiert.
  2. Fügen Sie eine Firewall-Regel hinzu, um den Datenverkehr zwischen Tableau Server-Instanzen zuzulassen, damit die Registrierung der Lizenzdienste nicht fehlschlägt.

Führen Sie tsm topology list-ports über eine Befehlszeile aus.
Achten Sie vor allem auf Ports mit "licenseservice:vendor_daemon". Erstellen Sie in der Firewall eine Regel, die folgende TCP-Verbindung (auf jedem Knoten) zulässt: 27000.

Der Lizenzserver-Port wird mithilfe von TSM topology set-ports für den Knoten, auf dem der Lizenzdienst installiert ist, hart kodiert.

tsm stop
tsm topology set-ports --node-name node1 --port-name licenseservice:vendor_daemon --port-value 27000
Restart licensing services
tsm restart

Zusätzliche Ressourcen

Das Problem testen

Windows
  1. Führen Sie tsm topology list-ports aus.
  2. Suchen Sie nach licenseservice:vendor_daemon (Daemon-Port des Lizenzdienstanbieters).
  3. Stellen Sie sicher, dass die Windows-Firewall den Datenverkehr zu den Ports für den Lizenzserver nicht blockiert. 
Sie können auch versuchen, die Windows-Firewall zu deaktivieren, und prüfen, ob ein Neustart des Servers mit TSM Start das Problem behebt. 

Prüfen, ob der Port richtig festgelegt wurde

Linux

cat /var/opt/tableau/tableau_server/data/tabsvc/config/licenseservice_0.<version>/tableau.lic
sudo netstat -ltnp | grep -w ":27000"

Weitere Informationen finden Sie unter Tableau Services Manager-Ports.
Nummer des Knowledge-Artikels

001471638

Anhänge

examplefailure.png

26 KB

 
Laden
Salesforce Help | Article