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Después del reinicio, los nodos de trabajo no aparecen y no se encuentra ningún archivo de registro

Fecha de publicación: Aug 24, 2022
Descripción
A partir de que el cliente reinició Windows Server, los procesos de Tableau Server muestran errores. Al mirar el panel de estado, todos los servicios de licencias en los nodos muestran errores.

Cause

Este error es genérico y podría estar relacionado con una causa raíz distinta.
El motivo por el que se produjo un error al cargar los servicios de licencias fue que los nodos no se registraron de forma adecuada. (INFO- com.tableausoftware.config.ServiceRegistrationInfoFile muestra que no se encontró ningún archivo de registro).
El problema se origina cuando el firewall bloquea el tráfico del servidor de licencias entre servidores de Windows. 

Solución
  1. La solución consiste en garantizar que el firewall no bloquee el tráfico a Tableau Server.
  2. Agregue una regla de firewall para permitir el tráfico entre servidores de Tableau. Así, no se producirán errores al registrar los servicios de licencias. 

Ejecute tsm topology list-ports desde una línea de comandos.
Tome nota de los puertos "licenseservice:vendor_daemon" específicamente. En el firewall, cree una regla que permita la siguiente conexión TCP (en cada nodo): 27000.

Integre el puerto del servidor de licencias como parte del código mediante TSM topology set-ports en el nodo donde está instalado el "Servicio de licencias".

tsm stop
tsm topology set-ports --node-name node1 --port-name licenseservice:vendor_daemon --port-value 27000
Reiniciar servicios de licencias
tsm restart

Recursos adicionales

Para verificar el problema

Windows
  1. Ejecute tsm topology list-ports.
  2. Busque licenseservice:vendor_daemon (Puerto del daemon del proveedor de servicios de licencias).
  3. Asegúrese de que el firewall de Windows no bloquee el tráfico a los puertos del servidor de licencias. 
También puede deshabilitar el firewall de Windows para probar si reiniciar el servidor con TSM Start ayuda a resolver el problema. 

Para verificar si el puerto se estableció correctamente

Linux

cat /var/opt/tableau/tableau_server/data/tabsvc/config/licenseservice_0.<version>/tableau.lic
sudo netstat -ltnp | grep -w ":27000"

Para obtener más información, consulte Puertos de Tableau Services Manager.
Número del artículo de conocimiento

001471638

Archivos adjuntos

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