Loading
Salesforce から送信されるメールは、承認済ドメインからのみとなります続きを読む

再起動後にワーカー ノードが起動せず、登録ファイルが見つからない

公開日: Aug 24, 2022
説明
顧客が Windows Server を再起動し、Tableau Server のプロセスが失敗を示しています。ステータス ペインを確認すると、ノード上のすべてのライセンス サービスが失敗を示しています。

Cause

このエラーは汎用であり、さまざまな根本的原因に関連している可能性があります。
ノードが正しく登録されていないことが原因で、ライセンス サービスの読み込みに失敗しました  (INFO- com.tableausoftware.config.ServiceRegistrationInfoFile は、登録ファイルが見つからないことを示します)。
この問題は、Windows Server 間でライセンス サービスのトラフィックがファイアウォールによってブロックされている場合に発生します。 

解決策
  1. 解決策として、Tableau Server へのトラフィックがファイアウォールによってブロックされていないことを確認します。
  2. ライセンス サービスが登録に失敗しないよう、Tableau Server 間のトラフィックを許可するファイアウォール ルールを追加します。

コマンド ラインから tsm topology list-ports を実行します。
"licenseservice:vendor_daemon" のポートに特に注意してください。 ファイアウォールで、各ノードのポート 27000 で TCP 接続を許可するルールを作成します。

"ライセンス サービス" がインストールされているノードに対して tsm topology set-ports を使用して、ライセンス サーバーのポートをハードコードします。

tsm stop
tsm topology set-ports --node-name node1 --port-name licenseservice:vendor_daemon --port-value 27000
ライセンス サービスを再起動します。
tsm restart

その他のリソース

問題をテストするには

Windows
  1. tsm topology list-ports を実行します。
  2. licenseservice:vendor_daemon (ライセンス サービス ベンダー デーモン ポート) を探します。
  3. ライセンス サーバー用のポートへのトラフィックが Windows ファイアウォールによってブロックされていないことを確認します。 
Windows ファイアウォールを無効にしてみて、TSM Start を使用したサーバーの再起動が問題の解決に役立つかどうかを確認することもできます。 

ポートが正しく設定されているかどうかを確認するには

Linux

cat /var/opt/tableau/tableau_server/data/tabsvc/config/licenseservice_0.<バージョン>/tableau.lic
sudo netstat -ltnp | grep -w ":27000"

詳細については、「Tableau サービス マネージャーのポート」を参照してください。
ナレッジ記事番号

001471638

添付ファイル

examplefailure.png

26 KB

 
読み込み中
Salesforce Help | Article