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Tableau Viz Lightning Web Component On Salesforce Mobile App Prompts for Sign-in

Date de publication: Apr 8, 2026
Description

Upon accessing an embedded Tableau view using "Tableau Viz Lightning Web Component" on Salesforce Mobile App, you are prompted for sign-in even though SSO with SAML is enabled.

Cause

This occurs due to the expiry and keep-alive mismatch between SAML and OAuth tokens.
 
Résolution

The only workaround to requiring users to sign-in each time is to deploy a multi-factor authentication (MFA) solution with SAML. In this scenario, when a user attempts to open a view, MFA will prompt for confirmation, resetting the OAuth token upon successful MFA confirmation.

Salesforce Multi-Factor Authentication FAQ

 

Numéro d’article de la base de connaissances

001471679

 
Chargement
Salesforce Help | Article