Loading

Error During Tableau Server upgrade: "The primary port for service gateway_0 was already registered on port 80 and cannot be remapped."

Publiseringsdato: Mar 3, 2025
Beskrivelse

Tableau Server upgrade fails with the following error:

 "The primary port for service gateway_0 was already registered on port 80 and cannot be remapped." 

or 


"UnableToFindAvailablePortException: Port 80 was already registered for port type gateway_0:primary but isn't available. Unable to remap port"

When this error occurred, you might have already set gateway.port to 80 using "tsm topology set-ports" and might have confirmed this using "tsm configuration get -k gateway.port".

You might be able to find that gateway.port is not configured 80 in the configuration file generated by "tsm settings export -f <file name>".

Cause

Port conflict with another process.

 
Løsning

Option 1

Configure gateway.port manually using "tsm configuration set" command:

tsm configuration set -k gateway.port -v 80
tsm pending-changes apply
Then execute upgrade script again.

Option 2 

Obliterate and clean install Tableau Server. In order to prevent this issue in a future identical upgrade, keep the default Gateway port (80) from the previous configuration until the upgrade is complete, where the Gateway Port can changed via the TSM Web UI, and Applying pending-changes. 
Knowledge-artikkelnummer

001471760

 
Laster
Salesforce Help | Article