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Fehler „reauth related error (invalid_rapt)“ beim Zugriff auf veröffentlichte BigQuery-Arbeitsmappen oder Aktualisierung von Extrakten

Veröffentlichungsdatum: Dec 9, 2022
Beschreibung

Beim Zugriff auf eine veröffentlichte BigQuery-Arbeitsmappe oder beim Aktualisieren von Extrakten tritt der folgende Fehler auf:

Confirm that you have provided valid credentials for this data source. (Bestätigen Sie, dass Ihre Anmeldeinformationen für diese Datenquelle korrekt sind.)
Unable to connect to data source with the supplied credentials, or no credentials provided. Mit den angegebenen Anmeldeinformationen kann keine Verbindung zur Datenquelle hergestellt werden bzw. es wurden keine Anmeldeinformationen bereitgestellt.)
Die bereitgestellten Anmeldeinformationen konnten nicht authentifiziert werden.
{“error” : “invalid_grant”,
“error_description” : “reauth related error (invalid_rapt)”,
“error_subtype” : “rapt_required”}

Oder 

Unable to connect to data source with the supplied credentials, or no credentials provided. (Mit den angegebenen Anmeldeinformationen kann keine Verbindung zur Datenquelle hergestellt werden bzw. es wurden keine Anmeldeinformationen angegeben.)
Die bereitgestellten Anmeldeinformationen konnten nicht authentifiziert werden.
{"InternalStatusCode":400,"message":"The provided grant or refresh token is invalid."} (Das angegebene Grant- oder Refresh-Token ist ungültig.)

Cause

Google hat eine Steuerung der Sitzungsdauer implementiert, die festlegt, wie lange Fremd-Anwendungen ein Refresh-Token verwenden können, um ein abgelaufenes Access-Token zu aktualisieren. 
Lösung
Verwenden Sie eine der folgenden Optionen, um das Problem zu umgehen. 

Option 1 Gespeicherte Anmeldeinformationen für alle BigQuery-Verbindungen löschen und neu hinzufügen
  1. Wenn Sie bei Tableau Server oder Tableau Cloud angemeldet sind, rufen Sie die Seite mit den Kontoeinstellungen auf.
  2. Wählen Sie unter Saved Credentials for Data Sources (Gespeicherte Anmeldeinformationen für Datenquellen) für den Benutzernamen neben Google BigQuery Löschen aus. 
  3. Wählen Sie Hinzufügen aus und geben Sie die Anmeldeinformationen für das BigQuery-Konto erneut ein. 
Hinweis: Wenn Sie BigQuery-Verbindungen veröffentlicht haben, die keine gespeicherten Anmeldeinformationen verwenden, finden Sie unter Bearbeiten von Verbindungen für Tableau Cloud Schritte für deren Aktualisierung. 
Hinweis: Durch die obigen Schritte zum Entfernen und erneuten Hinzufügen der Anmeldeinformationen wird die Gültigkeitsdauer des OAuth-Tokens aktualisiert, so dass die Aktualisierung für alle fehlgeschlagenen spezifischen Datenquellen erneut erfolgreich durchgeführt werden kann. Wenden Sie sich auch an den Anbieter der Datenquelle (Snowflake, Google BigQuery), um die Zeitüberschreitung der Token zu verlängern und diesen Fehler zu vermeiden.
Wie Sie die Gültigkeitsdauer des Tokens anpassen können, entnehmen Sie bitte der Dokumentation Ihres Datenquellenanbieters, oder wenden Sie sich an das zuständige Support-Team für Ihren Datenquellentyp.

Option 2 Erneutes Veröffentlichen der Arbeitsmappe oder Datenquelle mit eingebetteten Anmeldeinformationen in der Verbindung

Option 3 Tableau zur Ausnahmeliste für vertrauenswürdige Anwendungen hinzufügen
Informationen über das Hinzufügen von Tableau zur Liste der vertrauenswürdigen Ausnahmen für die Funktion der Sitzungsdauer finden Sie unter Beta: Festlegen der Sitzungsdauer für Google Cloud Services
Nummer des Knowledge-Artikels

001471808

 
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