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Error "reauth related error (invalid_rapt)" (error relacionado con reautorización) al acceder a los libros de trabajo de BigQuery publicados o al actualizar extracciones

Fecha de publicación: Dec 9, 2022
Descripción

Al acceder a un libro de trabajo de BigQuery publicado o al actualizar extractos, se produce el siguiente error:

Confirm that you have provided valid credentials for this data source. (Confirme que proporcionó credenciales válidas para esta fuente de datos).
Unable to connect to data source with the supplied credentials, or no credentials provided. (No se pudo conectar a la fuente de datos con las credenciales indicadas o no ha indicado sus credenciales).
No es posible autenticar el uso de credenciales de usuario suministradas.
{“error” : “invalid_grant”,
“error_description” : “reauth related error (invalid_rapt)”,
“error_subtype” : “rapt_required”}



Connectionless Failure (status code = 10000, Unable to connect to the data source with the supplied credentials, or no credentials provided. (Error sin conexión [código de estado = 10000]. No es posible conectarse a la fuente de datos con las credenciales indicadas o no se proporcionaron credenciales).
No es posible autenticar el uso de credenciales de usuario suministradas.
{"InternalStatusCode":400,"message":"The provided grant or refresh token is invalid."}

Cause

Google implementó un control de duración de sesiones a fin de establecer por cuánto tiempo las aplicaciones de terceros pueden utilizar un token de actualización para actualizar un token de acceso que caducó. 
Solución
Para solucionar este problema, intente una de las siguientes opciones. 

Opción 1: Eliminar las credenciales guardadas y volver a agregarlas para todas las conexiones de BigQuery
  1. Mientras está conectado a Tableau Server o Tableau Cloud, despliegue la página de configuración de la cuenta.
  2. En Credenciales guardadas para las fuentes de datos, seleccione Eliminar el nombre de usuario junto a Google BigQuery. 
  3. Seleccione Agregar y vuelva a introducir las credenciales de la cuenta de BigQuery. 
Nota: Si publicó conexiones de BigQuery que no utilizan credenciales guardadas, consulte los pasos para actualizarlas en Editar conexiones en Tableau Cloud
Nota: Con los pasos anteriores para quitar las credenciales y volver a agregarlas, se actualiza el período de validez del token de OAuth. La actualización comienza a ser efectiva nuevamente para todas las fuentes de datos específicas que fallaron. Consulte también el proveedor de fuentes de datos (Snowflake, Google BigQuery) a fin de extender el timeout de los tokens para evitar este error.
Si desea ajustar el período de validez de los tokens, consulte la documentación de su proveedor de fuentes de datos o póngase en contacto con el equipo de soporte correspondiente al tipo de fuente de datos.

Opción 2: Volver a publicar el libro de trabajo o la fuente de datos con credenciales integradas en la conexión

Opción 3: Agregar Tableau a la lista de aplicaciones de confianza
Si desea obtener información sobre cómo agregar Tableau a la lista de excepciones de confianza para la función de longitud de sesión, consulte Beta: establecer la longitud de sesión para los servicios de Google Cloud
Número del artículo de conocimiento

001471808

 
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