Loading

Diskrepanzen zwischen nativen Berichten und in Tableau importierten Salesforce-Daten

Veröffentlichungsdatum: Aug 24, 2022
Beschreibung

Die in einem Bericht in Salesforce dargestellten Daten stimmen nicht mit den in Tableau importierten Daten überein.

Cause

Die fehlende Übereinstimmung der Daten kann auf folgende Gründe zurückzuführen sein:
  • Die Salesforce-API, mit der Tableau Desktop eine Verbindung zu Salesforce-Daten herstellt, exportiert Datums- und Datum/Zeit-Felder in koordinierter Weltzeit (UTC).
  • Im Salesforce-Bericht werden andere Filter angewandt als in der Ansicht in Tableau.
  • Die Daten wurden aus dem Salesforce-Bericht zu einem anderen Zeitpunkt exportiert als beim Import der Daten aus Salesforce in Tableau. In dieser Zeit haben sich die Daten geändert.
Lösung
Verwenden Sie die folgenden Optionen, um dieses Problem zu beheben:

Option 1: Einrichten der Datenquelle durch Verknüpfen relevanter Tabellen, anstatt eine Standardverbindung zu verwenden

Die Nutzung von Tabellen anstelle einer Standardverbindung kann das Aufschlüsseln der Daten erleichtern, um die Diskrepanzen zu isolieren. Anstatt beispielsweise die Standardverbindung Aufgaben als Grundlage für die Replikation des Berichts Aktivitäten mit Leads in Salesforce zu verwenden, führen Sie einen Inner Join der Tabellen Lead und Aufgabe durch, wobei Lead ID = Name ID ist.

Eine Liste der Standardobjekte (entspricht Tabellen im Salesforce Connector) und ihrer Standardfelder finden Sie unter Standardobjekte im Salesforce SOAP API-Entwicklerhandbuch.
 

Option 2: Berücksichtigung von Zeitzonenunterschieden

Um die UTC-Zeitzonenausgabe für Datumsfelder zu konvertieren, wenn Sie den Salesforce-Konnektor verwenden, beachten Sie Option 2 unter Die Funktionen NOW() und TODAY() liefern Datumswerte in einer unerwarteten Zeitzone.
 

Option 3: Überprüfung der auf den Salesforce-Bericht angewandten Filter

Stellen Sie sicher, dass alle auf die Daten im Salesforce-Bericht angewendeten Filter gültig und für Ihre Analyse relevant sind.
 

Option 4: Exportieren der Daten aus dem Salesforce-Bericht als csv-Datei

Verbinden Sie dann Tableau mit der csv-Datei, um einen einfachen Vergleich mit der Arbeitsmappe zu ermöglichen, die den Salesforce-Konnektor verwendet.
 

Option 5: Sicherstellen, dass die Daten sowohl in der Tableau-Arbeitsmappe als auch im Salesforce-Bericht auf dem neuesten Stand sind

In Tableau Desktop können Sie den Verlauf der Aktualisierungen des Extrakts anzeigen, indem Sie die Datenquelle im Menü Daten und dann Extrakt > Verlauf auswählen. Klicken Sie mit der rechten Maustaste auf die Datenquelle im Datenbereich und wählen Sie Extrakt > Aktualisieren (vollständig) aus.

 
Nummer des Knowledge-Artikels

001471877

 
Laden
Salesforce Help | Article