Loading

Existen discrepancias entre los informes nativos y los datos importados en Tableau desde Salesforce

Fecha de publicación: Aug 24, 2022
Descripción

Los datos presentados en un informe dentro de Salesforce no coinciden con los datos importados en Tableau.

Cause

Esta discordancia de los datos puede deberse a los siguientes motivos:
  • La API de Salesforce que utiliza Tableau Desktop para conectarse a los datos de Salesforce exporta los campos de fecha y hora en formato Tiempo universal coordinado (UTC).
  • Se aplican filtros diferentes en el informe de Salesforce en comparación con la vista de Tableau.
  • Los datos se exportaron desde el informe de Salesforce a una hora diferente de la que se importaron en Tableau. Se produjo un cambio en los datos durante este tiempo.
Solución
Para solucionar este problema, use las siguientes opciones:

Opción 1: Configurar la fuente de datos mediante la unión de tablas relevantes en lugar de usar una conexión estándar

El uso de tablas en lugar de una conexión estándar puede facilitar el desglose de los datos para aislar las discrepancias. Por ejemplo, en lugar de usar la conexión estándar Tareas como base para replicar el informe Actividades con clientes potenciales en Salesforce, realice una unión interna de las tablas Clientes potenciales y Tareas donde el ID de cliente potencial = ID de nombre.

Puede consultar una lista de objetos estándar (equivalentes a las tablas del conector de Salesforce) en la Guía de desarrollador de la API de SOAP de Salesforce, así como sus campos estándar.
 

Opción 2: Considerar la diferencia de zona horaria

Para convertir el valor de zona horaria UTC de los campos de fecha al usar el conector de Salesforce, consulte la Opción 2 de Las funciones NOW() y TODAY() indican valores de fecha y hora en una zona horaria inesperada.
 

Opción 3: Comprobar los filtros aplicados al informe de Salesforce

Asegúrese de que todos los filtros aplicados a los datos en el informe de Salesforce sean válidos y relevantes para el análisis.
 

Opción 4: Exportar los datos del informe de Salesforce a un archivo CSV

A continuación, conecte Tableau al archivo CSV para poder compararlo fácilmente con el libro de trabajo que utiliza el conector de Salesforce.
 

Opción 5: Asegurarse de que los datos del libro de trabajo de Tableau y el informe de Salesforce estén actualizados

Para consultar un historial de cuándo se actualizó la extracción en Tableau Desktop, seleccione la fuente de datos en el menú Datos y seleccione Extracción > Historial. Para actualizar los datos, haga clic con el botón derecho en la fuente de datos del panel Datos y seleccione Extracción > Actualizar (Completo).

 
Número del artículo de conocimiento

001471877

 
Cargando
Salesforce Help | Article