Loading

ネイティブ レポートと Tableau にインポートされた Salesforce データ間の不一致

公開日: Aug 24, 2022
説明

Salesforce 内でレポートに表示されるデータが、Tableau にインポートしたデータと一致しません。

Cause

以下の理由により、データの不一致が発生する場合があります。
  • Salesforce データに接続するために Tableau Desktop が使用する Salesforce API は、日付フィールドと日時フィールドを協定世界時 (UTC) でエクスポートします。
  • Salesforce のレポートでは、Tableau のビューとは異なるフィルターが適用されます。
  • Salesforce のレポートからデータをエクスポートした日時が、Salesforce から Tableau にデータをインポートした日時と異なります。この期間中にデータの変更がありました。
解決策
この問題のトラブルシューティングを行うには、以下のオプションを使用します。

オプション 1 - 標準接続を使用する代わりに、関連するテーブルを結合してデータ ソースをセットアップする

標準接続の代わりにテーブルを使用すると、データにドリルダウンして不一致を特定することが容易になる場合があります。たとえば、Salesforce で "Activities with Leads (リード アクティビティ)" レポートを複製するための基礎として "Tasks (タスク)" 標準接続を使用する代わりに、"Lead (リード)" 表と "Task (タスク)" 表の内部結合を実行します (ここで、Lead ID (リード ID) = Name ID (名前 ID) です)。

標準オブジェクト (Salesforce コネクタのテーブルに相当) とその標準フィールドのリストについては、Salesforce SOAP API 開発者ガイドの「標準オブジェクト」を参照してください。
 

オプション 2 - タイムゾーンの違いを考慮する

Salesforce コネクタの使用時に日付フィールドの UTC タイムゾーン出力を変換するには、「NOW() および TODAY() 関数が予期しないタイム ゾーンの日時を返す」のオプション 2 を参照してください。
 

オプション 3: Salesforce レポートに適用されるフィルターを確認する

Salesforce レポートのデータに適用されるすべてのフィルターが有効であり、目的の分析に関連していることを確認します。
 

オプション 4: Salesforce レポートから csv ファイルとしてデータをエクスポートする

次に、Tableau を csv ファイルに接続して、Salesforce コネクタを使用するワークブックと比較しやすくします。
 

オプション 5: Tableau ワークブックと Salesforce レポートの両方でデータが最新であることを確認する

Tableau Desktop で、抽出がいつ更新されたかの履歴を確認するには、[データ] メニューでデータ ソースを選択して [抽出] > [履歴] を選択します。データを更新するには、データ ペインでデータ ソースを右クリックして [抽出] > [Refresh (Full) (更新 (完全)) を選択します。

 
ナレッジ記事番号

001471877

 
読み込み中
Salesforce Help | Article