Loading

Fehler "element...is not allowed for content model" bei dem Versuch, gespeicherte Kopien von veröffentlichten Datenquellen zu öffnen

Veröffentlichungsdatum: Oct 26, 2023
Beschreibung

Beim Öffnen einer heruntergeladenen Kopie einer veröffentlichten Datenquelle in Tableau Desktop 2018 oder höheren Versionen tritt unter Umständen folgender Fehler auf:

"error ####, ## element 'xxx' is not allowed for content model" ("Fehler ####, ## Element 'xxx' ist in einem Inhaltsmodell nicht zulässig")
 

Weitere Informationen zur Fehlermeldung: 

  • Dieser Fehler kann auch in veröffentlichten Arbeitsmappen auftreten, die von Tableau Server heruntergeladen wurden.
  • Die erste im Fehler angezeigte Zahl bezieht sich auf die Zeile der XML-Datei für die Arbeitsmappe oder Datenquelle, die zweite Zahl bezieht sich auf das Zeichen in der Zeile. 
  • Der Elementname ist das Tag, das den Fehler verursacht.

Cause

Bei Upgrades von Tableau Server auf 2018 und höhere Versionen kann es vorkommen, dass die XML-Datei aus Dateien, die häufig überarbeitet und neu veröffentlicht wurden, Elemente aus verschiedenen Versionen auswählt, basierend darauf, wie die Daten verwendet wurden (verschiedene Sortierungen, Änderungen an Aliassen usw.), und trotzdem die Version von Tableau Desktop beibehält, in der sie ursprünglich erstellt wurde. Wenn die Syntax für die Elemente oder die Elemente an sich nicht mit der Version in der XML-Datei übereinstimmen, können Fehler auftreten.
Lösung
  1. Setzen Sie die Arbeitsmappe/Datenquelle auf eine ältere Version zurück.
    1. Prüfen Sie, ob eine ältere Version der Datei verfügbar ist. Prüfen Sie, ob sie sich fehlerfrei in Tableau Desktop öffnen lässt und veröffentlichen Sie sie dann erneut.
    2. Nutzen Sie die Option "Revisionsverlauf" in Tableau Server, um zu prüfen, ob eine ältere Version der Datei zum Herunterladen vorhanden ist. Testen Sie diese Datei und veröffentlichen Sie sie dann erneut.
  2. Wenn das Problem weiterhin auftritt, eröffnen Sie einen Fall beim technischen Support von Tableau.
Nummer des Knowledge-Artikels

001471984

 
Laden
Salesforce Help | Article