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La connexion de Tableau Desktop à Tableau Server génère une erreur de certificat SSL avec une connexion SAML

Date de publication: Aug 24, 2022
Description

Lors de la connexion à Tableau Server depuis Tableau Desktop, le message d'erreur suivant s'affiche :

Cannot connect to Tableau Server. Please check the server name and port and try again. (Impossible de se connecter à Tableau Server. Vérifiez le nom du serveur et le port, puis réessayez.)
The host name did not match any of the valid hosts for this certificate (Le nom d'hôte ne correspondait à aucun des hôtes valides pour ce certificat)
The certificate is self-signed, and untrusted (Le certificat est auto-signé et non approuvé)


Bien que SSL ne soit pas configuré sur Tableau Server (et sans proxy ni équilibreur de charge), une erreur de validation du certificat SSL se produit lors de la connexion à Tableau Server. Les utilisateurs pourront se connecter à Tableau Server normalement dans un navigateur Web.

Toutefois, lorsque vous utilisez Tableau Desktop, le message d'erreur s'affiche lorsque la fenêtre d'authentification SAML tente de se charger et n'autorise pas l'utilisateur à poursuivre.

Cause

Tableau Desktop évalue le certificat SSL en ouvrant un portail sur le fournisseur d'identités SAML et indique que la validation du certificat a échoué plutôt que de poursuivre vers la page. Ceci peut se produire si l'IdP est hébergé en interne avec un certificat auto-signé géré via une stratégie de groupe par l'équipe informatique du client.
Résolution
Corrigez ou remplacez le certificat SSL non valide dans le portail Web du fournisseur d'identités SAML.
Ressources supplémentaires
Vous pouvez souhaiter que Tableau Desktop se connecte à Tableau Server sans authentification via SAML. Dans ce cas, cochez la case « wgserver.authentication.desktop_nosamlfalse ».
Si la valeur est « false », définissez-la sur « true ».

Dans une version pré-2018.2, Windows utilise ces commandes :
  • tabadmin set wgserver.authentication.desktop_nosaml true
  • tabadmin config
  • tabadmin restart
Numéro d’article de la base de connaissances

001472059

 
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Salesforce Help | Article