Loading

Fehler "Publish Failure" (Veröffentlichungsfehler) nach fehlgeschlagener Aktualisierung einer Datenquelle mit Tableau Bridge

Veröffentlichungsdatum: Oct 24, 2022
Beschreibung
Beim Aktualisieren einer veröffentlichten Datenquelle mit Tableau Bridge kann die Aktualisierung fehlschlagen und der folgende Fehler kann auftreten:

"Publish Failure" (Fehler beim Veröffentlichen)

Außerdem können die Tableau Bridge-Protokolle eine Fehlermeldung enthalten, z. B.:

"No such column [<column_name>]" (Keine entsprechende Spalte [<Spaltenname>])

Cause

 Dieser Fehler hat die folgenden Gründe:
  1. Die Datenquelle wurde mit einer älteren Version von Tableau Desktop veröffentlicht als mit der aktuellen Version von Tableau Cloud.
  2. Und seit der ursprünglichen Veröffentlichung der Datenquelle wurde der Datenbank entweder eine Spalte hinzugefügt oder aus ihr entfernt.
Wenn die Versionen von Tableau Desktop und Tableau Cloud nicht übereinstimmen, werden im Hintergrund zusätzliche Prozesse ausgeführt, was zu der Fehlermeldung "No such column" (Keine entsprechende Spalte) während der Aktualisierung führen kann. Wenn sie übereinstimmen, entfallen diese zusätzlichen Prozesse und die Aktualisierung ist erfolgreich.
Lösung
  1. Beenden Sie Tableau Bridge.
    • Hinweis: Wenn Tableau Bridge im Service-Modus ausgeführt wird, setzen Sie es zunächst in den Anwendungsmodus und beenden Sie es dann. Dadurch wird sichergestellt, dass der Client nach dem Verlassen der Benutzeroberfläche nicht im Hintergrund weiterläuft.
  2. Schließen Sie alle offenen Sitzungen von Tableau Desktop.
  3. Laden Sie die neueste Version von Tableau Desktop herunter und installieren Sie sie. Sie ist über Ihr Tableau-Portal oder unter www.tableau.com erhältlich: https://www.tableau.com/de-de/support/releases
  4. Melden Sie sich bei Ihrer Tableau Cloud-Site an und navigieren Sie zur Datenquellenseite für eine der fehlgeschlagenen Datenquellen.
  5. Klicken Sie auf die Schaltfläche Herunterladen und speichern Sie die .tdsx-Datei.
  6. Öffnen Sie Tableau Desktop und verwenden Sie Datei > Öffnen, um die gespeicherte .tdsx-Datei zu öffnen.
  7. Klicken Sie mit der rechten Maustaste auf die Datenquelle und wählen Sie Extrakt > Aktualisieren.
  8. Veröffentlichen Sie nach Abschluss der Extraktaktualisierung die Datenquelle erneut. Stellen Sie sicher, dass Sie denselben Projekt- und Datenquellennamen wie die ursprünglich veröffentlichte Datenquelle verwenden.
  9. Öffnen Sie Tableau Bridge und aktualisieren Sie die Datenquelle erneut.
Nummer des Knowledge-Artikels

001472081

 
Laden
Salesforce Help | Article