Loading

Error de publicación después de una actualización errónea de una fuente de datos con Tableau Bridge

Fecha de publicación: Oct 24, 2022
Descripción
Al actualizar una fuente de datos publicada con Tableau Bridge, puede fallar la actualización y producirse el siguiente error:

"Error de publicación"

Además, los registros de Tableau Bridge pueden contener un mensaje de error como el siguiente:

"No existe la columna [<nombre_columna>]"

Cause

 Este error se produce por las siguientes razones:
  1. La fuente de datos se publicó con una versión de Tableau Desktop más antigua que la versión actual de Tableau Cloud.
  2. Como la fuente de datos se publicó originalmente, se agregó una columna o se eliminó de la fuente de datos.
Cuando las versiones de Tableau Desktop y Tableau Cloud no coinciden, se hace un trabajo adicional en segundo plano que puede provocar un error de "no existe dicha columna" durante la actualización. Si coinciden, el trabajo adicional no se lleva a cabo, por lo que la actualización se realiza correctamente.
Solución
  1. Salga de Tableau Bridge.
    • Nota: Si Tableau Bridge se está ejecutando en el modo de servicio, configúrelo para que se ejecute en el modo de aplicación y, a continuación, salga de la configuración. Esto garantiza que el cliente no siga ejecutando en segundo plano después de salir de la IU.
  2. Cierre todas las sesiones abiertas de Tableau Desktop.
  3. Descargue e instale la versión más reciente de Tableau Desktop, disponible en el portal de Tableau o en https://www.tableau.com/es-es/support/releases
  4. Inicie sesión en el sitio de Tableau Cloud y vaya a la página de fuente de datos de una de las fuentes de datos que esté fallando.
  5. Haga clic en el botón Descargar y guarde el archivo .tdsx.
  6. Abra Tableau Desktop y use Archivo > Abrir para abrir el archivo .tdsx que ha guardado.
  7. Haga clic con el botón derecho en la fuente de datos y seleccione Extraer > Actualizar.
  8. Después de que la actualización de la extracción se haya completado, publique de nuevo la fuente de datos. Asegúrese de que está utilizando el mismo nombre de proyecto y de fuente de datos que la fuente de datos original publicada.
  9. Abra Tableau Bridge y vuelva a actualizar la fuente de datos.
Número del artículo de conocimiento

001472081

 
Cargando
Salesforce Help | Article