Loading

Error "Errors occurred while loading the data source" (Se produjeron errores al cargar la fuente de datos) al conectarse a archivos de Excel

Fecha de publicación: Jul 27, 2023
Descripción
Al conectarse a archivos de Excel, podría producirse el siguiente error en Tableau Desktop:

"Errors occurred while loading the data source" (Se han producido errores al cargar la fuente de datos)

O bien 


An error occurred while communicating with data source '<data source name>' (Se produjo un error durante la comunicación con la fuente de datos "<nombre de fuente de datos>").
Errors occurred while loading the data source. (Se han producido errores al cargar la fuente de datos)
Unable to connect to the server (No es posible conectarse al servidor) Check that the server is running and that you have access privileges to the requested data base.
(Compruebe que el servidor esté en ejecución y que disponga de privilegios de acceso para la base de datos solicitada).

Cause

Este error puede deberse a distintos motivos, entre ellos:
  • El archivo de Excel está dañado.
  • La ruta del archivo de Excel cambió.
  • El archivo de Excel es de una versión antigua que tiene la extensión .xls.
Solución

Opción 1: Posible archivo dañado

  1. Abra el archivo de Excel afectado.
  2. Copie todos los datos en el archivo.
  3. Pegue los datos en un nuevo archivo de Excel.
  4. Guarde este nuevo archivo de Excel.
  5. Conecte Tableau Desktop a este nuevo archivo de Excel.

Opción 2: ¿Cambió la ruta del archivo?

En Tableau Desktop:
  1. Abra el libro de trabajo de Tableau Desktop.
  2. Haga clic con el botón derecho en la fuente de datos en el panel Datos en la parte superior izquierda de la ventana y seleccione Editar fuente de datos... 
  3. Haga clic en el nombre del archivo de Excel y asegúrese de que la conexión apunte a la ruta de archivo correcta. Puede encontrar esta opción en Conexiones > menú desplegable <fuente de datos> > Editar conexión...
  4. Si la ruta de archivo es incorrecta, vuelva a establecer una conexión con el archivo de Excel ubicado en la ruta de archivo correcta.
Para Tableau Server/Cloud
Es importante comprender si los datos se publicaron por separado o si se insertaron en un libro de trabajo publicado.

Si los datos se publicaron por separado, puede usar el método "copia local" descrito en el artículo de la base de conocimientos Editar una fuente de datos publicada a fin de determinar la ruta del archivo y hacer los ajustes necesarios para después volver a publicar la fuente de datos. 

Si los datos se insertaron en un libro de trabajo, descárguelo de Tableau Server o Tableau Cloud, siga los pasos de la Opción 2 y vuelva a publicar el libro de trabajo.

Opción 3: Tipo de archivo antiguo

Si está usando un archivo que se creó en una versión muy anterior de Microsoft Excel, tendremos que cambiar la extensión del archivo de .xls a .xlsx.  
  1. Abra el archivo de Excel en Microsoft Excel y, a continuación, guárdelo con la extensión .xlsx.  
  2. Abra Tableau Desktop, Tableau Server o Tableau Cloud y vuelva a conectarse al archivo.xlsx.  
Número del artículo de conocimiento

001472091

 
Cargando
Salesforce Help | Article