Loading

Erreur : « Errors occurred while loading the data source » (Des erreurs se sont produites lors du chargement de la source de données) lors de la connexion à des fichiers Excel

Date de publication: Jul 27, 2023
Description
Lors de la connexion à des fichiers Excel, l'erreur suivante peut se produire dans Tableau Desktop :

"Errors occurred while loading the data source" (Des erreurs se sont produites lors du chargement de la source de données)

OU 


An error occurred while communicating with data source '<data source name>'. (Une erreur s'est produite lors de la communication avec la source de données '<nom de la source de données>'.)
Errors occurred while loading the data source. (Des erreurs se sont produites lors du chargement de la source de données.)
Unable to connect to the server. (Impossible de se connecter au serveur.) Check that the server is running and that you have have access privileges to the requested data base. (Vérifiez que le serveur est en cours d'exécution et que vous disposez de privilèges d'accès à la base de données demandée.)

Cause

Cette erreur peut survenir pour de multiples raisons, par exemple :
  • Le fichier Excel est endommagé.
  • Le chemin d'accès au fichier Excel a changé.
  • Le fichier Excel a été créé à partir d'une version obsolète et porte une extension .xls
Résolution

Option 1 - Fichier potentiellement endommagé

  1. Ouvrez le fichier Excel concerné.
  2. Copiez toutes les données du fichier.
  3. Collez les données dans un nouveau fichier Excel.
  4. Enregistrez ce nouveau fichier Excel.
  5. Connectez Tableau Desktop à ce nouveau fichier Excel.

Option 2 - Le chemin d'accès au fichier a-t-il changé ?

Dans Tableau Desktop :
  1. Ouvrez le classeur Tableau Desktop.
  2. Faites un clic droit sur la source de données dans le volet Données en haut à gauche de la fenêtre et sélectionnez Modifier la source de données… 
  3. Cliquez sur le nom de fichier Excel et vérifiez que la connexion pointe vers le chemin d’accès de fichier correct. Vous trouverez cette option sous Connexions > Menu déroulant <data source> > Modifier la connexion…
  4. Si le chemin d'accès est incorrect, établissez à nouveau une connexion au fichier Excel qui se trouve sur le chemin d'accès au fichier correct.
Pour Tableau Server/Cloud
Il est important de savoir si les données ont été publiées séparément ou à quel moment elles ont été intégrées dans un classeur publié.

Si les données sont publiées séparément, vous pouvez les copier en local, comme indiqué dans l'article de la base de connaissances intitulé Modification d'une source de données publiée, afin de déterminer le chemin d'accès au fichier et d'apporter les modifications nécessaires avant de republier la source de données. 

Si les données sont intégrées à un classeur, téléchargez-le depuis Tableau Server ou Tableau Cloud, suivez les étapes de la section Option 2 et republiez le classeur.

Option 3 - Type de fichier obsolète

Si vous utilisez un fichier créé à l'aide d'une version très ancienne de Microsoft Excel, vous devrez remplacer l'extension .xls par .xlsx.  
  1. Ouvrez le fichier Excel dans Microsoft Excel, puis enregistrez-le avec l'extension .xlsx.  
  2. Ouvrez Tableau Desktop, Tableau Server ou Tableau Cloud et accédez au fichier .xlsx.  
Numéro d’article de la base de connaissances

001472091

 
Chargement
Salesforce Help | Article